Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

2 CGO3's with Problems

Discussion in 'Q500 4K Help' started by Brodee, Jun 10, 2016.

  1. Brodee

    Joined:
    Jun 6, 2016
    Messages:
    10
    Likes Received:
    0
    I have 2 q500 4k's, both with CGO3's on them and both with problems.

    The first will transmit video and everything works fine except the camera tilt on the ST10+. If I try to tilt it beeps but doesn't move the camera. If I put the camera on the steady grip the tilt works. Am I missing a setting on my ST10+ somewhere that has the tilt wheel disabled?

    The 2nd was in a crash before I got it and now the gimbal motors don't seem to do anything. The video works and all else works fine but the camera just hangs there and flops around when the Q moves. No visual damage and no wires disconnected. Do I need to replace the control board? If so do they sell it separate and does anyone know the part number?

    Any help with these issues is much appreciated as I'm anxious to get them both flying good and fly with my son.

    Thanks!
     
  2. Steve Carr

    Steve Carr Moderator
    Staff Member

    Joined:
    Dec 15, 2015
    Messages:
    902
    Likes Received:
    401
    Location:
    Bessemer, MI
    The tilt could be the connection between the camera and the Q. If you are using the 3 wire connector, unplug it and reattach to see if that fixes the problem. If you aren't using it, then try it. It bypasses the 3 contacts on the slide mount.
    As far as the camera with no gimbal action, I suggest calling Yuneec. They can repair it and I think the cost is reasonable.
     
  3. Brodee

    Joined:
    Jun 6, 2016
    Messages:
    10
    Likes Received:
    0
    Steve, thanks for the response. I am using the 3 wire connector as all 3 of the cameras I have are missing the original wires that break for everyone. I use that same 3 wire connector on the steady grip and it works fine.

    I'll call Yuneec on the other one and see what they can do.
     
  4. ruckuss

    Joined:
    Jun 14, 2016
    Messages:
    5
    Likes Received:
    0
    Any news on this? I have the same problem with a cgo3
     
  5. DarkWhiteChocolate

    Joined:
    Jun 10, 2016
    Messages:
    60
    Likes Received:
    23
    Same tilt issue here, as well as crooked video...
     
  6. ComicGamer

    Joined:
    Oct 6, 2016
    Messages:
    8
    Likes Received:
    0
    Yuneec will charge you $150 to repair the gimbal.
    They will say it is your fault.
    Mine came back and died within a week.
    Three tiny wires to power a $600 camera prone to being in crashes?

     
  7. Louie

    Joined:
    Oct 26, 2016
    Messages:
    18
    Likes Received:
    2
    I had the same problem after a crash. It turned out to be the camera control board.