Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

  1. Mick Dixon

    Joined:
    Jan 25, 2016
    Messages:
    19
    Likes Received:
    4
    Location:
    Maitland, Australia
    I'm trying to charge my battery. This is only the third time it has been charged. The first two times it was fine. This time the lights on the charger are blinking green..red.......red. It says on the charger if it flashes green..red that it is balancing the charge. Not sure why I'm getting the extra red. It has been on the charger for about 8 hours. Any help would be greatly appreciated.
     
  2. Subtle Shots

    Joined:
    Oct 8, 2015
    Messages:
    121
    Likes Received:
    26
    Location:
    Aliso Viejo southern California
    Mine blinks red for about ninety minutes then blinks red/green until the charge is completely done balancing all three cells.
    Buy a cell balance checker....you can check your levels very easily. ...two are shown in my picture.
    Looks like your charger is trying to complete a battery cell balance routine. Try charging it in your car....or unplug and replug in the wall....the bigger battery checker shiwn in my picture really helps to analyze the condition of each battery....I use mine all the time.
     

    Attached Files:

  3. Subtle Shots

    Joined:
    Oct 8, 2015
    Messages:
    121
    Likes Received:
    26
    Location:
    Aliso Viejo southern California
    Carolina drones sell this one.....it beeps really loud upon first time insertion, and acts as a low voltage alarm also.
    Just bend back or cut off the pins so only four remain on top right with the digital display facing up.
    Then turn the battery upside down to insert the checker correctly.
    It shows all cells, total voltage.
    Then goes thru a continuous cycle of showing cell one, cell two, cell three, all....over and over.
     

    Attached Files:

  4. Mick Dixon

    Joined:
    Jan 25, 2016
    Messages:
    19
    Likes Received:
    4
    Location:
    Maitland, Australia
    Think I've sourced the problem. Had a blown fuse. Seems to be charging normally now. One for the data banks. It seems that green...red......red = blown fuse. Thanks for all your input.
     
  5. Tecneek

    Joined:
    Dec 21, 2015
    Messages:
    133
    Likes Received:
    16
    Now, the question is why did the fuse blow?