Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

Camera Broken off Gimbal

Discussion in 'Q500 4K Help' started by Unscript, Jan 4, 2016.

  1. Unscript

    Joined:
    Jan 4, 2016
    Messages:
    2
    Likes Received:
    0
    So on my new qt500 drone i noticed that the camera actually had NO connection to the gimbal. The wires are on connected but the camera is not physically connected to the part that swivels the camera left and right. I was wondering if i could just glue the two parts together and all would be fine? I would use some extremely strong glue of course. images below to show what i am talking about. what do you all think? IMG_0573.JPG IMG_0572.JPG
     
  2. wedbster

    Joined:
    Dec 19, 2015
    Messages:
    227
    Likes Received:
    47
    I don't believe you find a glue that has the power to fix it on this little surface
     
  3. Unscript

    Joined:
    Jan 4, 2016
    Messages:
    2
    Likes Received:
    0
    do you know where i could get the part that is missing from it then so i can fix it?
     
  4. bshaker Air4c 1

    Joined:
    Dec 29, 2015
    Messages:
    129
    Likes Received:
    39
    Your Q is new and is probably still under warranty. Spending that kind of money is not worth superglueing and half stepping with your quad. What if it comes back apart in flight. Do the right thing and contact Yuneec and explain your situation, they have excellent customer service, and they're always willing to resolve your issue.
     
    wedbster likes this.