Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

Crash at start up?! Didn't even touch control?

Discussion in 'Q500 4K Help' started by MILES MILLER, May 21, 2016.

Tags:
  1. MILES MILLER

    Joined:
    May 21, 2016
    Messages:
    3
    Likes Received:
    1
    On the boat yesterday, I went to launch off the bow as I have always done. All satellite connected. Everything ready. Led purple in angle mode. I press the red button to start the motors. At that moment the motors start. I'm not touching any of the controls. The motors seemed to throttle up on their own flipping it on its side and almost off the boat into the lake. Broke 3 propellers luckily getting caught up on the rails around the bow. Lost all confidence as of now to fly over water. Why would it take off and flip at startup? Only crash I've had and it's drone error. Not pilot error. Please help
     
  2. DroneClone

    Joined:
    Mar 2, 2016
    Messages:
    1
    Likes Received:
    8
    Location:
    Texas
    Where you in Smart Mode by chance? That would answer all!:rolleyes:
     
  3. MILES MILLER

    Joined:
    May 21, 2016
    Messages:
    3
    Likes Received:
    1
    Angle mode
     
    DroneClone likes this.
  4. MILES MILLER

    Joined:
    May 21, 2016
    Messages:
    3
    Likes Received:
    1
    Local RC shop said it could have been the accelerometer reading The Rock of the boat and trying to adjust
     
  5. DroneClone

    Joined:
    Mar 2, 2016
    Messages:
    1
    Likes Received:
    8
    Location:
    Texas
    Good ! They don't seem to take off well from bouncy location from my experiences!