Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

  1. Baymax

    Joined:
    Jun 9, 2016
    Messages:
    16
    Likes Received:
    6
    Hi all,

    Wondering if anyone has experienced the issue I have with my TH. Most of the time very happy, but yesterday it did it again, 3rd time in about 50 flights:
    When I put the left stick down for smooth landing, the H slows down by itself at about 30 ft (10 meters) , and won’t respond to command for going further down , it is just stopping there and hovering at the same altitude of 30ft while I am pulling the left stick fully down . It’s also twitching a little bit, nothing serious though, but not having usual behavior.

    Then I have to push left stick for getting some altitude, there it responds and going up. Then I go down again, and after 4-5 attempts, it is finally going down to the ground.

    Is there something to do with accelerometer ?

    I have done firmware update, compass calibration, issue remains.

    Would anyone have an idea of what this could be?

    Thank you
     
    #1 Baymax, Aug 7, 2016
    Last edited: Aug 7, 2016
    basnite and Badala like this.
  2. JCFlippen

    Joined:
    May 11, 2016
    Messages:
    481
    Likes Received:
    167
    Location:
    Cardiff-Wales UK
    Have you gone into Smart Mode by accident? I had this on one occasion (not Smart Mode) a few weeks ago out of 40 flights and switched to RTH and home it came.
     
  3. Badala

    Joined:
    Apr 26, 2016
    Messages:
    29
    Likes Received:
    20
    Mine did The SAME...
     
  4. QuadBart

    Joined:
    Jan 19, 2016
    Messages:
    356
    Likes Received:
    111
    Location:
    USA
    So you did the same thing take it up and make additional attempts at landing till it did land?

     
  5. Badala

    Joined:
    Apr 26, 2016
    Messages:
    29
    Likes Received:
    20
    I was desperate mine didn't go down further than 3 meters...I needed to go on a ladder (I was in my home garden) and catched it by the landing gear then I terminated the motors
     
  6. Dragonflyerthom

    Joined:
    May 7, 2016
    Messages:
    1,129
    Likes Received:
    354
    Location:
    Guidon, Ar
    If this happens then try RTH then flip back to Angel mode then bring it down. This is what I would do. Return to home will take it back up to 10 meters then back down. Flipping to Angel puts you back in control. Stay out of smart mode unless you are in one of the auto pilot modes, i.e. Orbit follow me etc. Then back to Angle. Fly safe.
     
  7. Rayray

    Rayray Moderator
    Staff Member

    Joined:
    Jun 3, 2016
    Messages:
    1,231
    Likes Received:
    388
    Location:
    Pine Forests of Deep East Texas
    Curious. You said "put the right stick down for smooth landing". Did you mean to say left stick? You re-calibrated everything? Once on the ground, what is the altitude reading?
     
    abinder likes this.
  8. Baymax

    Joined:
    Jun 9, 2016
    Messages:
    16
    Likes Received:
    6
    Yes sorry, meant "left stick"
     
  9. Baymax

    Joined:
    Jun 9, 2016
    Messages:
    16
    Likes Received:
    6
    No, I was in ANGLE mode all the time
     
  10. Haydn

    Joined:
    May 19, 2016
    Messages:
    189
    Likes Received:
    38
    Location:
    Brisbane Australia
    I would also try RTH, just make sure you have a clear area in front of you.
     
  11. deonjams

    Joined:
    Jul 29, 2016
    Messages:
    10
    Likes Received:
    0
    Had the same problem, 1st flight with h2 (have 2, 1st is h1, h1 no issue) and it gets stuck at 30ft, does not want to descend. RTH does not make it come down. Altitude stick down made it go UP a little every time. Altitude read -ve even though it was 30+ft up. Unnerving. Eventually figured out keeping full down stick made it come down slowly. Grabbed it out of sky at head height. Next flight opposite, it thought it was HIGHER than what it was, and landed heavily. Was told by Yuneec to recalibrate/set up everything (except camera of course). After successful compass and gyro calibration, problem still existed. Suspect faulty barometer/altitude sensor. Yuneec replaced it, replacement still to be tested as not home until next week. Test would be to hover stationary, and height indicator continuously changes (up or down). Faulty altitude indication...
     
  12. Badala

    Joined:
    Apr 26, 2016
    Messages:
    29
    Likes Received:
    20
    Mine did The same today. I landed at -13 meters...
     
  13. Batfire

    Joined:
    Jul 17, 2016
    Messages:
    92
    Likes Received:
    19
    Location:
    Connecticut
    Stupid question: Did you guys turn off the collision avoidance before beginning the landing sequence?
    Just wondering? If so I will sit back and see what the final verdict is...... that what came to mind.

    Cheers

    Batfire
     
  14. deonjams

    Joined:
    Jul 29, 2016
    Messages:
    10
    Likes Received:
    0
    Wonder what the issue is - have asked but no reply yet. Am an experienced flier (all RC including helis), and set up and checked everything before flying the H. First one was faultless - everything went well including RTH testing, obstacle avoidance etc. Very happy with performance so I bop a second one. With the second one, this issue appeared, and it seems to be a common issue.
    Of course, and in angle mode. The clear issue as we both stated was the erroneous height reading. It's fine if it's slightly out (temperature changes), but this much, and rapidly changing even while stationary? Have heard of the issue going away when redoing calibration, but mine didn't. Will try and figure out the reason behind the issue
     
  15. Batfire

    Joined:
    Jul 17, 2016
    Messages:
    92
    Likes Received:
    19
    Location:
    Connecticut
    Man..... Im baffled also I thought this was only occurring with the Q500+4k. I have same issue come down to within a foot or so of landing and then it will not land. I usually force it then crosshand by hitting the motor switch and it plops down. I thought maybe I was just doing something wrong and actually sat down tonight and was rereading the manual just in case. I have not had the H up yet, just got it and wanted to fully read the online manual until I was satisfied I can do everything without having to think. So really this issue is not just with H series but Q500 series also just hasn't gotten as bad as you guys are experiencing. So the collision avoidance is not really the issue if I have issues with the Q. It has to be something in the programming maybe with the barometer calibration? Dont ask I have no idea how you would calibrate that but I did have this issue years ago with early version of the Xaircraft controllers and I found what it was. The hole became clogged that allowed the pressure to equalize in controller for the barometer. This caused off readings such as you guys seem to be experiencing . I think NAZA also had this issue, I remember reading something on that a couple of years ago when they were hot.

    Just a thought.

    Cheers

    Batfire
     
  16. Dewster

    Joined:
    Jun 5, 2016
    Messages:
    24
    Likes Received:
    11
    I had that happen on my first flight. It left me shaking considering the cost and size of the aircraft. I was tempted to push the red button to kill motors, but the cost of the thing kept me from doing so. I was flying in angle mode too. Obstacle avoidance was off, the aircraft was facing away from me. I was about 12 feet off of the ground and the craft would not land. I've only experienced this once. It may have something to do with turtle mode. The slowest setting for (extreme positioning) turtle mode makes the H harder to land. I think it may even prevent it from landing. This is just a theory. I'll have to test it on my next flight.
     
  17. Batfire

    Joined:
    Jul 17, 2016
    Messages:
    92
    Likes Received:
    19
    Location:
    Connecticut
    Hmm..... Dewster,

    You might be on to something, I to will have to test that with the Q500 first then follow up on the H once I get thru memorizing the manual and do the first flight or two. I have a few different copters so not rushing the H.

    Cheers

    Batfire
     
  18. deonjams

    Joined:
    Jul 29, 2016
    Messages:
    10
    Likes Received:
    0
    Someone else advised not being in turtle mode. I don't fly in turtle, but I wasn't at max hare either. As mentioned it is also inconsistent, does not always repeat itself. Happened on my 1st and 4th flights, 2nd and 3rd flights were opposite, came down hard.

    There must be a reason why mine was replaced, still trying to get an answer. Will test replacement later this week, let the thread know
     
  19. basnite

    Joined:
    Jun 22, 2016
    Messages:
    4
    Likes Received:
    0
     
  20. basnite

    Joined:
    Jun 22, 2016
    Messages:
    4
    Likes Received:
    0
    Hi!.........You have a problem with your gps module, or barametric pressure sensor or both. most likely the barametric pressure sensor. If it is under warrenty , ask for an RMA to send it back thru customer service. it should be back in about 7 days, start to finish. cheers!!!