Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

Problem with cam CG03

Discussion in 'Q500 4K Help' started by federico, Aug 31, 2016.

  1. federico

    Joined:
    Aug 28, 2016
    Messages:
    3
    Likes Received:
    1
    Hi all,
    I crashed my drone and the CG03 camera ripped apart from the Yuneec Typhoon body mount. The wires that go into the gimbal were ripped from the internal PCB boards. The gimbal rubber dampeners were also separated from the mount.
    i used the cable as in this video,



    all working but i cannot move camera up/down

    anyone can help me?

    Thks a lot :(
     
    ComicGamer likes this.
  2. Steve Carr

    Steve Carr Moderator
    Staff Member

    Joined:
    Dec 15, 2015
    Messages:
    902
    Likes Received:
    401
    Location:
    Bessemer, MI
    I'm a bit confused about which wires were broken. Was it the 3 wires coming from the back of the gimbal or the wires inside the gimbal?
    Two of the wires supply power to the gimbal and camera from the Q500. The third wire is the one that sends the signal to move the camera up and down.
     

    Attached Files:

  3. federico

    Joined:
    Aug 28, 2016
    Messages:
    3
    Likes Received:
    1
    Hi, all three wires (black) from the back of the gimball. i tryed with the cable as in the video up , but only video and power comes...it's impossible move the cam also with the steadygrip :(
     
  4. Steve Carr

    Steve Carr Moderator
    Staff Member

    Joined:
    Dec 15, 2015
    Messages:
    902
    Likes Received:
    401
    Location:
    Bessemer, MI
    Ouch!! Sorry to hear that. I think there is a problem internally with the gimbal. You need to call Yuneec. It sounds like they will have to repair it. They are very good and the repair will not be expensive.
     
  5. federico

    Joined:
    Aug 28, 2016
    Messages:
    3
    Likes Received:
    1
    i hope so :(

    Best Regards
     
  6. Toolman

    Joined:
    Sep 11, 2016
    Messages:
    17
    Likes Received:
    2
    I did the same thing with mine. Hard crash onto concrete....after it hit my roof and rolled up it then back down it to the ground.
    My cam did the same thing. Wouldn't tilt. I called yuneec and there labor cost was $80 an hour.
    The tech told me that the camera and gimbal are 1 unit so buying the gimbal wasn't an option. I looked into getting a new camera $499.
    It will make you sick.
    I never found a fix for it. I opted not to have yuneec repair it because I found a steadygrip with a case, lipo battery that came with the 4k cgo3 camera for $349.
    Would Ithat been cheaper having them fix it....maybe alittle or maybe they would have said it wasn't worth fixing. .....
    $349 is alot of money but it isn't $499
    And I do fly more carefully now.
    Hope you can get it repaired cheaply. If not look on Amazon
     
  7. ComicGamer

    Joined:
    Oct 6, 2016
    Messages:
    8
    Likes Received:
    0
    Got my camera back from repair and it cost me $150 to replace the gimbal.

    Video and power work but gimbal stopped working after a week.
     
  8. Toolman

    Joined:
    Sep 11, 2016
    Messages:
    17
    Likes Received:
    2
    Have you tried to reach bind it?
    I've had mine stop working and had to go into flight settings and select it.
     
  9. ComicGamer

    Joined:
    Oct 6, 2016
    Messages:
    8
    Likes Received:
    0
    Yeah. Did various methods for rebinding as well.

    Gimbal just won't initialize and no tilt controls.
    I get video feed though