Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

Propellers flew off

Discussion in 'Q500 Help' started by Dan M, Aug 8, 2016.

  1. Dan M

    Joined:
    Aug 8, 2016
    Messages:
    2
    Likes Received:
    0
    Greetings , after tightening props well , set it all up and gave it throttle and rear 2 props flew off , any chance they are wired backwards .
    Thanks Dan M:(
     
  2. Sparkorc

    Joined:
    May 24, 2016
    Messages:
    281
    Likes Received:
    73
    I had one prop do that when I first got my H just as I started the motors, I think this was due to being in a rush to get in the air in this occasion I did not double check each prop was securely fastened, I've now got in the habit of holding each motor in turn and try and the same time, twist each prop clockwise & anti clockwise to check they are securely locked in place, not had one fly off since hope this helps you out.


    Sorry ignore what I said I mistook you was referring to the Typhoon H props flying off, but as I have the Q500 4k also it maybe you did not tighten the two props quite enough down onto the rubber o ring.
     
    #2 Sparkorc, Aug 8, 2016
    Last edited: Aug 8, 2016
  3. Dan M

    Joined:
    Aug 8, 2016
    Messages:
    2
    Likes Received:
    0
    Actually I carefully checked a and b and tightened them all fairly tight any tighter and I would fear a break .
    Thanks for the reply
     
  4. Louie

    Joined:
    Oct 26, 2016
    Messages:
    15
    Likes Received:
    2
    You might want to change the "O" rings.