Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

  1. ProbeT

    Joined:
    Jun 19, 2016
    Messages:
    8
    Likes Received:
    3
    I have not found the procedure in the manual to set my ST16 clock to my local time zone (Eastern Daylight savings). I have tried selecting an East Coast city (NYC) but the GMT - 4 hrs is incorrect (for this time of year), and displays the local time as an hour earlier than it really is. Also the time stamp on my pics and videos is hours off. I have tried setting the time on both the ST16 option and through the clock on the Pad and neither has worked. Is there something I have overlooked? Solutions anyone? Thanks!

    Probe
     
  2. jwjohnson

    Joined:
    May 28, 2016
    Messages:
    61
    Likes Received:
    16
    Many posts on this. There is a bug that makes it end up an hour off.
     
  3. ProbeT

    Joined:
    Jun 19, 2016
    Messages:
    8
    Likes Received:
    3
    Thank you! I called the Yuneec customer support line and the rep didn't tell me that. he told me how to go to the Pad and pull up the clock to make changes and that was it. I thought, 'how simple could this be, so what am I missing'? I could have saved a lot of time if he had just told me what you did. Thanks again.

    Probe
     
    jwjohnson likes this.
  4. Pedwergos

    Joined:
    Sep 15, 2016
    Messages:
    22
    Likes Received:
    4
    I think I may have a workaround as was having the same issue.

    Go to PAD and tablet settings => date & time and set the correct time of your location. Go out of settings using the back button, but don't go back to FPV view. Switch off the ST16.

    Switch back on and check the time in the FPV.

    This has worked for me.
     
  5. Pedwergos

    Joined:
    Sep 15, 2016
    Messages:
    22
    Likes Received:
    4

    Ah... maybe not... Still the same after GPS lock. A fix it shall have to be.