Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

  1. skyfotos.net

    Joined:
    Jan 8, 2017
    Messages:
    2
    Likes Received:
    2
    Hi everyone,

    I've seen a lot of threads here from users reporting that they can't connect GUI Software Version 1.01. After installing the software (incl. the virtual com port driver) it wouldn't recognize the Typhoon H when connected via USB cable (in neither mode: USB nor Serial Port).

    I've found the reason to be the STM Virtual COM Port Driver, so I've updated to their newest one from this website: STSW-STM32102 - STM32 Virtual COM Port Driver - STMicroelectronics - STMicroelectronics

    After restarting the machine it works to connect the GUI Software via the "Serial Port" Method. It still doesn't connect via the "USB" method, but at least one method works.

    By the way I am using a Mac and the Parallels VM to run Windows. Of course you need to tell Parallels to assign the Typhoon to the Windows 7 machine and not to the Mac.

    I hope this helps.

    Karl
     
    CC Rider likes this.
  2. CC Rider

    Joined:
    Dec 19, 2016
    Messages:
    81
    Likes Received:
    19
    Location:
    Riverdale Park, Delaware USA
    WAY TO GO!!

    I've been searching for an answer to this problem for weeks and got nowhere. But after downloading the link you provided and installing the new software, the GUI interface is working like a charm. Not even a Yuneec tech knew to tell me this just a few days ago.

    Thanks a lot for the solution, Karl. Now I can see what I've been missing and use another part of what I've paid for. Really appreciate it.
     
    skyfotos.net likes this.
  3. CC Rider

    Joined:
    Dec 19, 2016
    Messages:
    81
    Likes Received:
    19
    Location:
    Riverdale Park, Delaware USA
    I posted this (below) today in a thread I started a while ago inquiring if the GUI program was still being used and valid. Thanks for the help. Happy Flying!

    Posted Today:
    Note that new forum member skyfotos.net (Karl) has found the solution to this problem. (I initially wrote "The final solution," but realized THAT phrase has a very negative history and connotation!)

    Apparently there WAS something wrong with the STM GUI interface download for the Typhoon H as it appeared on Yuneec's download page, prohibiting the software from operating properly or connecting to the aircraft. Skyfotos.net (Karl) provided this link: STSW-STM32102 - STM32 Virtual COM Port Driver - STMicroelectronics - STMicroelectronics (found in his thread on the Typhoon H Help page titled "[SOLVED] GUI Connection...." posted yesterday) to a new STM GUI program download that fixes the problems found in Yuneec's errant GUI download.

    Hats off to Karl. I downloaded the link he posted, installed the updated software, and the GUI was up and running as it should be, connecting fine with the Typhoon. A Yuneec tech I spoke with just days ago was clueless about this solution to their problem. So I thank Karl for providing the correct answer to this problem that had so many stumped.
     
    skyfotos.net likes this.
  4. Ruud Hogenberg

    Joined:
    Nov 24, 2016
    Messages:
    23
    Likes Received:
    4
    I did the above procedure on my WIN10 laptop. Can confirm it works for me.
    First time i could use the GUI to test the motors and saw all sensors working.
    Thanks and cheers to both
     
    skyfotos.net likes this.
  5. skyfotos.net

    Joined:
    Jan 8, 2017
    Messages:
    2
    Likes Received:
    2
    Great it works for you as well!
     
    Ruud Hogenberg likes this.
  6. Ruud Hogenberg

    Joined:
    Nov 24, 2016
    Messages:
    23
    Likes Received:
    4
    Thanks skyfoto, its ofcourse odd that there is no solution from yuneec themselves. Seems there priority is in development and not in trouble shooting



    Verzonden vanaf mijn iPad met Tapatalk