Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

  1. Cdunc2003

    Joined:
    Sep 16, 2016
    Messages:
    5
    Likes Received:
    1
    Hey everyone! I'm new to the Yuneec community..just bought the Typhoon H, and flew it for the second time yesterday. Flights went fine, but the ST16 is not doing well..

    When I tried to turn the ST16 on last night for flight 3, it wouldn't turn on...no fans, no splash screen, etc...just the blue light next to the power button was lit up. I wasn't able to get it started, so I was dealing with it this morning (12 hours later), I took it out of the case and the screen/center of the unit was warm...the power button was off.

    So I put a call into Yuneec and will send an email, but I wanted to see if anyone else had any similar issues?

    Thanks in advance

    Chuck D. - Salisbury, Mass.
     
  2. BillyTexas

    Joined:
    Aug 2, 2016
    Messages:
    618
    Likes Received:
    169
    Never had that problem. Do the cooling fans come on? Both of them?

    Bill W.
     
  3. Cdunc2003

    Joined:
    Sep 16, 2016
    Messages:
    5
    Likes Received:
    1
    Hey Bill, thanks for the reply. No fans come on at all, nor did the screen.

    At this point, because of it heating up like it did, I've disconnected the battery and will have to wait to hear from Yuneec. I don't need a fire.

    -Chuck D.
     
  4. BillyTexas

    Joined:
    Aug 2, 2016
    Messages:
    618
    Likes Received:
    169
    Was the battery warm or hot?

    Bill W.
     
  5. Cdunc2003

    Joined:
    Sep 16, 2016
    Messages:
    5
    Likes Received:
    1
    At first I thought the battery was warm..but I actually think the heat was from the screen itself. The area that was warm on the unit was exactly in the area of the screen. It just bothers me that it happened with the power button in the off position.
     
  6. BillyTexas

    Joined:
    Aug 2, 2016
    Messages:
    618
    Likes Received:
    169
    Well...now the battery is out....treat it like a hard reboot. Now reinstall the battery and try turning it on one more time. You can still contact yuneec even if it works good.

    Bill W.
     
  7. Cdunc2003

    Joined:
    Sep 16, 2016
    Messages:
    5
    Likes Received:
    1
    Bill, thanks! I'll give it a shot!
    Chuck
     
  8. BillyTexas

    Joined:
    Aug 2, 2016
    Messages:
    618
    Likes Received:
    169
    Let me know if that works.

    Bill W.
     
  9. Cdunc2003

    Joined:
    Sep 16, 2016
    Messages:
    5
    Likes Received:
    1
    Hey Bill, just a follow up..

    Just plugged the battery back in, flipped the power button on, and had the same results...just the blue light came on, no fans or splash screen.

    Good news is, I talked with Yuneec support yesterday, and they are sending me a new ST 16 tomorrow. They also have never heard of this happening.... figures I'm the first! They agreed that the best thing to do was immediately unplug the battery from the unit, under no circumstances should it have heated up that way.

    So, thanks for responding... hopefully next one will be fine!

    Thanks,
    Chuck D
     
    BillyTexas likes this.
  10. RCT

    RCT

    Joined:
    Nov 6, 2016
    Messages:
    1
    Likes Received:
    0
    I experienced the same issue (except mine didn't get hot). When I powered it on I got nothing on the display, the blue light came on then got brighter after a few seconds (like normal). When I moved the controls I would hear beeps but nothing else. After several troubleshooting steps (i.e. removing the battery for extended periods of time, searching for a recovery boot option, etc).

    This was the first time I have had to charge the ST16 as the drone has barely been flown. So I took it off the charger provided by Yuneec in the box and tried an Android phone charger that I have laying around.

    After 15 minutes I turned on the controller and it's back!! So it turns out that the charger provided in the box not only does not charge the ST16 but it drains the battery!!