Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Battery charge question

Joined
May 13, 2016
Messages
187
Reaction score
33
Age
46
I got my adapter from Geko and hooked it up to my new IMAX B6AC v2 charger. Set it to balanced LiPo and it charged the H battery at 1C .

90 minutes later the charger was cycling between 16.79v and 16.80v. Didn't seem like it was going to shut off so I just stopped the charging.

I'm new to all this but it seemed to me it should have finished before and hour and half otherwise I'm not doing much better than the stock charger.
 
Joined
Jul 5, 2016
Messages
385
Reaction score
149
Location
Eagle ID
I got my adapter from Geko and hooked it up to my new IMAX B6AC v2 charger. Set it to balanced LiPo and it charged the H battery at 1C .

90 minutes later the charger was cycling between 16.79v and 16.80v. Didn't seem like it was going to shut off so I just stopped the charging.

I'm new to all this but it seemed to me it should have finished before and hour and half otherwise I'm not doing much better than the stock charger.
How many amps were you charging at and what was the voltage of the different cells? Maybe it was trying to bring one cell up or down to balance it. 90 minutes does seem very long.
 
Joined
May 13, 2016
Messages
187
Reaction score
33
Age
46
Charging at 5.4A per cell. Don't recall the individual voltages on that battery. Did a second battery and it's on 96 minutes. Cells 4.19, 4.19,4.20,4.20.
 
Joined
Jul 22, 2016
Messages
157
Reaction score
67
Age
45
I have had only limited opportunities to charge batteries and I have two that charge pretty fast using the same adapter from Geko and a Hittec charger. Two batteries charge in in that 2 hour'ish range, but two of them take over 600 min to charge using balanced mode.

The balance mode starts off at the 1C (5.4amps) and slowly scales down power but near the 98% full area it keeps going and going for that 600 min range before the charge detects its full. The battery fly's fine BTW. Also the cells all report pretty balanced voltage during the full charge cycle (doesn't vary more that 0.1 volts.)

On fast charge they charge normal time.

I have changed ports and used different cables (I have 4 of them) and they all do the same 600+ min charge with those two batteries.
I gave up solving it and had them swapped out under warranty.
 
Joined
Jul 16, 2016
Messages
316
Reaction score
66
Age
61
I have had only limited opportunities to charge batteries and I have two that charge pretty fast using the same adapter from Geko and a Hittec charger. Two batteries charge in in that 2 hour'ish range, but two of them take over 600 min to charge using balanced mode.

The balance mode starts off at the 1C (5.4amps) and slowly scales down power but near the 98% full area it keeps going and going for that 600 min range before the charge detects its full. The battery fly's fine BTW. Also the cells all report pretty balanced voltage during the full charge cycle (doesn't vary more that 0.1 volts.)

On fast charge they charge normal time.

I have changed ports and used different cables (I have 4 of them) and they all do the same 600+ min charge with those two batteries.
I gave up solving it and had them swapped out under warranty.
10 hours ?


Sent from my iPhone using Tapatalk
 
Joined
Jul 22, 2016
Messages
157
Reaction score
67
Age
45
10 hours ?


Sent from my iPhone using Tapatalk
Yup, over 10 hours... I know its not right.... thats why I sent them back....
I'm not thrilled about the situation. I have another one that us creating up in time also. I don know if its because I have not used them much (They are always in storage more when I'm done with them). or something else.... either way, I'm ignoring this issue largely now as I'm not sure I'm keeping the H... it keeps finding ways to not work great.
 
Joined
Dec 28, 2015
Messages
483
Reaction score
151
Age
74
Location
STATEN ISLAND NEW YORK
I got my adapter from Geko and hooked it up to my new IMAX B6AC v2 charger. Set it to balanced LiPo and it charged the H battery at 1C .

90 minutes later the charger was cycling between 16.79v and 16.80v. Didn't seem like it was going to shut off so I just stopped the charging.

I'm new to all this but it seemed to me it should have finished before and hour and half otherwise I'm not doing much better than the stock charger.
once your battery reaches 12.80 your battery is fully charged , some chargers when you balance charge will take a while because the amp it is charging drops to below 1 amp to balance the 4 cells . below is a voltage chart .Lipoly Voltage vs. State of Charge 2S - 6S Packs.JPG
 
Joined
Apr 5, 2016
Messages
86
Reaction score
43
Age
64
I am no expert but I am pretty sure it is your charger. If you really want to charge Yuneec H batteries fast spring for a 200 watt charger. If you look at your instruction manual it might tell you that it is capable of 6 amp but only when using DC voltage. I don't know if that is the case with yours but they are pretty sneaking when advertising specs only to find out after you have bought it that they were not lying but it is not exactly what you thought you were getting.
 

PatR

Premium Pilot
Joined
May 1, 2016
Messages
10,099
Reaction score
5,455
Location
N. California
Sounds like the charge rate actual is at ~.1C. I use a Hitec charger and they are done in ~ an hour.
 
Joined
Jul 22, 2016
Messages
157
Reaction score
67
Age
45
Sounds like the charge rate actual is at ~.1C. I use a Hitec charger and they are done in ~ an hour.
are you using balance charge or fast charge... I can get about an hour with fast charge.... in balance mode it takes between 90 and 120 min
 
Joined
May 10, 2016
Messages
1,646
Reaction score
681
Age
64
Location
Melvin Michigan, In the thumb
I use a Hitec X2.
Same for me, I can charge a battery from about 14.8 volts to full charge (6 amps) in an hour or less.
Using balance charge it take 90 minutes or so.
I have sat and watched a few batteries ( using the charge master and my laptop) and even in fast charge mode it still balance charges. It looks like when in balance mode, it fast charges to a point, then you can see the charge amperage drop by about 2 amps and then it looks like it switches from cell to cell to charge the rest of the way.
Still faster than the Yuneec charger and I can do 2 batteries at once. Never had a battery even get warm during charging, and I use temperature probes on mine.
The Yuneec charger generates quite a bit of heat, that rises and makes you battery warm durring the charge process.
 
  • Like
Reactions: NRRTRAINS

PatR

Premium Pilot
Joined
May 1, 2016
Messages
10,099
Reaction score
5,455
Location
N. California
are you using balance charge or fast charge... I can get about an hour with fast charge.... in balance mode it takes between 90 and 120 min
Bob and I appear to use the same charger.

I use balance charge for every charge cycle, however, I don't deep discharge my batteries. My lowest battery voltage when starting a charge is 14.7v, with the average closer to 15.0v, so it does not require as much time to return to peak voltage. I trade off a little flight time for a longer battery life cycle.
 
  • Like
Reactions: abinder

New Threads

Forum statistics

Threads
17,023
Messages
198,793
Members
19,687
Latest member
MiniMike