Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Breeze 4K Binding

Sep 27, 2022
Reaction score
Hello and sorry if I start a new conversation.
I state that I am NOT a professional but I am passionate about everything related to modeling (even if the drones, of which I speak, are in my opinion a very soft category of modeling).
I have 3 Trex an Embla, cars, motorcycles, trucks and I am completing what I think is a very interesting object as a reproduction. Chinook Ch47 from Vario.
Having said all this, I come to the why of this post.
I "dusted off" a Yuneec Brezze 4K purchased in October 2016, used quite then "forgotten" following the purchase of a Phantom 4.
Tried to put it back in the air without success. One because the batteries were giving an error, two because I can't connect it with the iPad.
Solved the batteries by connecting the misfiring battery of each pack to the charger I use for other batteries with 0.1A current and 4.0V disconnection. Once this was done (it took me a long time) I tried again with the original charger and…. Everything is fine.
As for the connection, however, nothing to do.
The iPad sees it as a network but says "no connection"
Seen several videos on the web, also tried to reset the Breeze with the key next to the usb socket but nothing, it does not connect.
I know the Breeze is a bit old but can someone help me? It is useless to hear the parent company as from the videos posted on youtube everyone says that the house asks to send the Breeze for inspection, you get nothing and you spend on “back and forth” shipments.
It being understood that there is a big difference between the Breeze and the Phantom, I would still like to fly it again
Thanks in advance to all those who can give me some tips in this regard.
Good flights
Welcome to YuneecPilots!

There is one thing in your description of the problem that makes me think you do have a WiFi connection to the Breeze, and that is the statement of “no connection”. I am sure you are in the Settings, WiFi menu on your iPad and once connected to the Breeze AP it states “no internet connection” and that is normal for the Breeze. If you get the check mark showing a connection then open the Breeze Cam app and open a Task and see if you get a video feed from the camera.

This thread will help troubleshoot connection issues How To: Troubleshoot the Breeze and Request Help in the Forum. It gives step by step sequence of connecting to the Breeze WiFi.

There are several sticky threads in the Breeze sub forums here that cover WiFi issues.
  • Like
Reactions: Pier2162

New Posts

Members online

Forum statistics

Latest member