Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Camera won't Initialize or connect (post crash)

Joined
Apr 6, 2017
Messages
23
Reaction score
13
Age
71
I was busy avoiding obstacles and wind gusts and forgot to lower the landing gear, ended up "landing" on the camera. Now the camera won't initialize and the console can't connect to it.

Any suggestions would be most welcome.

Thanks
 
Joined
May 10, 2016
Messages
1,645
Reaction score
685
Age
66
Location
Melvin Michigan, In the thumb
Remove the gimbal, check the electrical contacts, make sure one did not get stuck down or popped out of place.
 
Joined
Apr 6, 2017
Messages
23
Reaction score
13
Age
71
How do I "remove the gimbal"? I see there's some kind of gray tab underneath the gimbal platform, but it doesn't seem to do anything when pushed.
Not sure if it's damage but 2 of the rubber isolation cups (diagonally located) are only attached to the "floating" gimbal, the other 2 rubber cups are attache at both ends.
 
Joined
Apr 6, 2017
Messages
23
Reaction score
13
Age
71
I took BobW55's advice; removed the gimbal, replaced, and Voila! it works per normal - thanks Bob.

BTW: Are all 4 rubber isolation cups supposed to be attached at both ends?
 
Joined
Sep 14, 2016
Messages
61
Reaction score
22
Age
60
Location
Jervis Bay NSW, Australia
All four isolation cups should be attached to the gimbal cover top and bottom, but only two (diagonally opposites) will have the plastic pin in them. These are a safety measure to stop the camera coming off if the rubber isolation cups (dampeners) pop out of the gimbal cover.
 

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
8,148
Reaction score
4,618
Location
Bessemer, MI
I took BobW55's advice; removed the gimbal, replaced, and Voila! it works per normal - thanks Bob.

BTW: Are all 4 rubber isolation cups supposed to be attached at both ends?
Did you get the rubber dampers reinstalled?
 
Joined
Apr 6, 2017
Messages
23
Reaction score
13
Age
71
The 2 pinned ones never came loose.
I think I succeeded in getting one of the dampers which detached at the fixed (non-floating) end reattached - but the other one refuses to reattach at the fixed end.
Is there some procedure/tool for attaching those things?

Thanks
 
Joined
Sep 14, 2016
Messages
61
Reaction score
22
Age
60
Location
Jervis Bay NSW, Australia
I have found the easiest way is to use a small length of dental floss, wrap it around the top of the dampener a couple of times then thread the other end through the plate and gently work the dampener in by pulling the floss. You can also try a little drop of water as lubricant or a wet finger.
 

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
8,148
Reaction score
4,618
Location
Bessemer, MI
The 2 pinned ones never came loose.
I think I succeeded in getting one of the dampers which detached at the fixed (non-floating) end reattached - but the other one refuses to reattach at the fixed end.
Is there some procedure/tool for attaching those things?

Thanks
If you are working on the ones that have the black plastic pin through them you can just cut the pin and toss it. Replace it after the damper is re-installed with 2 wire ties. Put one wire tie trough the center of the damper and then slide the other one on it. Cut the tail off the second one and trim the first to length. Keep it loose. Too tight and it will restrict movement of the rubber.
 

PatR

Premium Pilot
Joined
May 1, 2016
Messages
10,802
Reaction score
6,311
Location
N. California
The easiest way is to remove the top cover cap that prevents you from seeing the top of the vibration dampers. I'm guessing you are trying to re-install them with the cover still in place.
 
Joined
Apr 6, 2017
Messages
23
Reaction score
13
Age
71
Thanks for all the replies and solutions.
I just stopped back in after a long and arduous campaign of putting those little suckers back in.
...must be some kind of psychic going on, I finally hit upon using dental floss.
Until I hit on the use of dental floss I was sure the camera platform isolation was in need of a big redesign, now I'm not so sure.
 

New Threads

Members online

Forum statistics

Threads
19,963
Messages
230,931
Members
24,238
Latest member
rfagriculture