Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

CG03 camera with a Typhoon G

Joined
Sep 13, 2018
Messages
234
Reaction score
137
Age
46
Hi everyone,
I got a used Typhoon G kit at a steal minus the camera and I already have a second CG03 I use for interior real estate photography on a handheld grip. The CG03 won't tilt on the Typhoon G but it works fine on the handheld assembly and on my Q500 k, which indicates either the G is not wired in a compatible manner, or I need a different cable from the CG03 to the drone. Has anyone else done this upgrade, and if so what is the workaround? I would much rather buy a cable than a new camera!

Thanks for any input,
Chef
 

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
6,038
Reaction score
2,678
Location
Bessemer, MI
The Q500 series is fairly consistent internally. Does the G have a slide mount for the CGO3 camera?
 
Joined
Sep 13, 2018
Messages
234
Reaction score
137
Age
46
Yes, it has a slide mount. I tried all of the usual troubleshooting tricks. The camera binds, etc. just fine. It works perfect on the handheld grip and I even tried installing and binding it on my newer Q500 and it works perfect. I have run through the process several times, so it is likely the cable to the Typhoon G, or the drone itself. This afternoon I will take a closer look at the slide plate pins, but upon initial inspection they all look fine - nothing bent or out of place.
 

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
6,038
Reaction score
2,678
Location
Bessemer, MI
Yes, it has a slide mount. I tried all of the usual troubleshooting tricks. The camera binds, etc. just fine. It works perfect on the handheld grip and I even tried installing and binding it on my newer Q500 and it works perfect. I have run through the process several times, so it is likely the cable to the Typhoon G, or the drone itself. This afternoon I will take a closer look at the slide plate pins, but upon initial inspection they all look fine - nothing bent or out of place.
This is the connector inside the Q500 where the camera plugs in. It's a small circuit board and it may be bad on your Q.

CameraConnector2.jpg
 
Joined
Sep 13, 2018
Messages
234
Reaction score
137
Age
46
Thank you for the response. Since I got it for spare parts I don't mind spending a little money to bring it back to trim. It came with aftermarket carbon fiber props, a working battery, a working ST10+ and a few other items and it flies perfect. After a full teardown (Yunecc has cornered the market on small Allen screws!) I have determined that it has to be the circuit board you mentioned or the one going to the slide plate that has the contacts on it, or the cable that goes from the slide plate bracket to the mainboard. I am searching now for those replacement parts.
 

New Threads

Forum statistics

Threads
15,321
Messages
177,550
Members
17,986
Latest member
Lasvegasdroneguy