Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

CGO3+ shows rotorarms when making a panorama

Joined
Dec 20, 2021
Messages
17
Reaction score
1
Age
44
Since i while the CGO3+ shows the rotorarms in the upper part of the image when making a panorama.
I don't know if it has to do with it that the unit once crashed, because everything seems to work good
and even the gimbal doesn't show any anomalities.
The camera gives a strait horizon when placed on a flat surface.

Any idea on how to fix this?
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
3,310
Reaction score
2,568
Location
North Carolina Piedmont, USA
It sounds like the top "travel stop" is broken off the front shell. If you look closely with a good light into the gap between the left hub cover and the camera shell, you should be able to see two little plastic travel stops. If there is only one (or none), you will need to replace the front shell.
 
Joined
Dec 20, 2021
Messages
17
Reaction score
1
Age
44
It sounds like the top "travel stop" is broken off the front shell. If you look closely with a good light into the gap between the left hub cover and the camera shell, you should be able to see two little plastic travel stops. If there is only one (or none), you will need to replace the front shell.
You mean the shell of the CGO3+ ?
 
Joined
Sep 28, 2020
Messages
973
Reaction score
329
Age
53
Location
Kozloduy, Bulgaria
Didn't understand the question.

Prepare a stopper from a small bolt instead of the original plastic one.
 

New Threads

Members online

Forum statistics

Threads
20,371
Messages
235,929
Members
25,375
Latest member
Pavlo