Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

CGO3+ wiring problem and question

Joined
Jul 4, 2016
Messages
9
Reaction score
1
Age
50
Has anyone crashed and had to re-wire the small circuit board w the new Typhoon H CGO3+ camera?? I soldered a few back but cannot tell where the red wire went. Any help is appreciated! ThanksIMG_3324.JPGIMG_3325.JPG
 
  • Like
Reactions: Tomki04
Joined
Jul 8, 2016
Messages
5
Reaction score
0
Age
37
so Jon, how did it go? I have the same problem. unfortunately, the wires were pulled off from the solder. So there's no way tracing which color is to which.I tried to copy what you did there but it seems it's not working.... Can you guide me to which colors is to which? thanks.
 
Joined
Jul 9, 2016
Messages
2
Reaction score
1
I took mine apart, the red is soldered to the same contact as the blue, VBAT.
 
Joined
Jul 8, 2016
Messages
5
Reaction score
0
Age
37
Thanks Erikt. So basically, Jon's wiring is correct except for the red wire which should be with the blue. right?
 
Joined
Jul 8, 2016
Messages
5
Reaction score
0
Age
37
Thanks Erikt. I finally got the gimbal working. Unfortunately, It only works for the steady grip. I cant control the pan and tilt through st16... Figured that im not getting any supply from the drone port. see attached pic... the white one with K value is a fuse and is busted so i jumped that fuse and the gimbal works but still doesnt pan or tilt from the controller.
 

Attachments

Joined
Jul 28, 2016
Messages
1
Reaction score
0
Age
49
Hey there, i hawe same problem,i crashed the drone and the wires get out,and i solded them back,but i cant cotroll pan and tilt in controller st16.The gimbal itself its working fine.
Got any news about it ?

-Mika-
 
Joined
Jul 31, 2016
Messages
1
Reaction score
0
Age
40
I wired mine back and nothing is working still no power to camera any ideas ?
 
Joined
May 22, 2016
Messages
16
Reaction score
4
Age
38
I too am working to fix this. The white wire seems to have came loose in this swivel connection. Can anyone tell me how to remove this metal sleeve ?



Sent from my iPad using Tapatalk
 
Joined
May 22, 2016
Messages
16
Reaction score
4
Age
38
Ok. I managed to remove the sleeve and the way the wires ripped out, I need this part. Anyone know how or where to locate just this part?



Sent from my iPad using Tapatalk
 
Joined
Jul 7, 2016
Messages
174
Reaction score
89
Age
41
hate to say but you will not be able to get those parts. not even from Yuneec. its a total lose
 
Joined
Sep 11, 2016
Messages
17
Reaction score
2
Age
42
Does the crash kit not have that piece included?
I just had this happen to me and I ordered that kit. $66 off amazon. Shows it comes with the connection board
 
Joined
Sep 11, 2016
Messages
17
Reaction score
2
Age
42
Joined
Jul 4, 2016
Messages
9
Reaction score
1
Age
50
Does the crash kit not have that piece included?
I just had this happen to me and I ordered that kit. $66 off amazon. Shows it comes with the connection board
OK nice to know. It wasn't available when I needed it. Yuneec repaired for a total of $53. However, doesn't matter now as I had a fly away and no longer with the drone. Guess I'll need to get another to start back up.
 
Joined
May 19, 2016
Messages
560
Reaction score
222
Age
48
Location
Brisbane Australia
How did you get the sleeve off?
Ok. I managed to remove the sleeve and the way the wires ripped out, I need this part. Anyone know how or where to locate just this part?



Sent from my iPad using Tapatalk
 
Joined
Nov 19, 2016
Messages
1
Reaction score
0
Age
55
Location
Finland
I wired mine back and nothing is working still no power to camera any ideas ?
I have same problem. After crash I bought a new camera and there´s no power to camera. Is there somekind fuse on the main board or is the main board broken?

Sorry my bad english but I am silly finnish :)
 

New Threads

Forum statistics

Threads
16,631
Messages
193,831
Members
19,291
Latest member
Crisner00