Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Corrupt Video

Joined
Dec 4, 2017
Messages
4
Reaction score
0
Age
25
Hi everybody

So I got a little problem: I flew this Saturday, it was really cold (-13°C; yes i flew with heated LiPos). Everything worked fine, took a bunch of photos and a video (4K25, about 4Mins long).
The Photos are fine and look great. But: As soon as I landed, I shut down the H, immediateley after noticing: "Darn, I had a video recording still running".

So later, back at home, I copied all the files from the Card to my computer, only to find the MP4 file corrupt.
I thought "Ah, I already had this sometimes, pop it up in VLC, it should play". It didn't.

Well to keep it short, here's what I tried:
* Open in VLC => failed
* Convert with VLC => failed
* Fix with "Video Repair" from Grau => failed
* Pop it back in the H and start a new recording, to "finish" the old video => didn't do nothing
* Fix with "Digital Video Repair" => failed

So, all I got now is a defective Video, that's telling me it's got a duration of 4 seconds. When you play it, it's all black. Filesize is 1.71 GB.

Does anybody know, what I can do?

Thanks a lot and have a nice day!
 

FlushVision

Premium Pilot
Joined
Jun 19, 2016
Messages
2,975
Reaction score
1,287
Age
64
Location
Shaw, Gtr Manchester, U.K.
Usually, putting the card back into the camera and starting & stopping recording usually fixes a file after the aircraft had been switched off without stopping the recording. However, I suspect that this procedure is more likely to work if nothing else has been done with the file like copying to another device.

With a file size of 1.71 GB it seems to me that all of the data is there. Maybe someone else can suggest a fix, since beyond using the above method I have no answers.
 
  • Like
Reactions: biltno
Joined
Jul 4, 2017
Messages
4,159
Reaction score
1,921
Age
63
Location
Ocoee, Florida
Flush is correct, just put the card back into the camera, turn on the ST, turn on the H, once you get camera view on ST turn on the record button for a few seconds then turn camera off. You should have video now.
 
Joined
Dec 4, 2017
Messages
4
Reaction score
0
Age
25
Did exactly that. Did absolutely nothing. :/
 
Joined
Jul 4, 2017
Messages
4,159
Reaction score
1,921
Age
63
Location
Ocoee, Florida
What SD card r u using? Also VLC does not like large files. Download GOM player it's free and better to use
 
Joined
Aug 1, 2017
Messages
128
Reaction score
41
Age
42
Did exactly that. Did absolutely nothing. :/
You may have to reformat the card. I did this twice. When you shut the power of on the h when video is recording it will either corrupt the file or not record the video. I have never been able to recover the corrupted files. It sucked because it was a great video both times. I even did it on my spark and same thing. The video was gone. So in the future try to remember to stop recording before shutting down.
 

CraigCam

Premium Pilot
Joined
Oct 1, 2016
Messages
1,517
Reaction score
649
Age
60
For what it’s worth, the ST recorded the flight in 720. It may not be perfect but it’s there. Look in your gallery.
 

PatR

Premium Pilot
Joined
May 1, 2016
Messages
10,161
Reaction score
5,516
Location
N. California
Best thing you can do is to remember to stop the video before shutting down the H. Corrupt videos are generally due to operator error, not a system failure.
 
Joined
Jul 4, 2017
Messages
4,159
Reaction score
1,921
Age
63
Location
Ocoee, Florida
I've accidentally shut off before stopped recording. I restarted and did what I said above, never lost or had corrupt files. :confused::)
 

rdonson

Premium Pilot
Joined
Jul 24, 2017
Messages
2,032
Reaction score
859
Location
Davidson, NC USA
If you’ve got a binary editor I wonder if the video file is simply missing an end of file marker if things are not shut down as expected.
 
Joined
Dec 4, 2017
Messages
4
Reaction score
0
Age
25
Thanks for all your answers! Appreciate it!

For what it’s worth, the ST recorded the flight in 720. It may not be perfect but it’s there. Look in your gallery.
Yeah, I know. Sadly this video is pretty blocky and stuttering, as I flew pretty far away. But thanks.

What SD card r u using? Also VLC does not like large files. Download GOM player it's free and better to use
I use a normal 16GB microSD, UHS3. GOM couldn't play it either.

You may have to reformat the card. I did this twice. When you shut the power of on the h when video is recording it will either corrupt the file or not record the video. I have never been able to recover the corrupted files. It sucked because it was a great video both times. I even did it on my spark and same thing. The video was gone. So in the future try to remember to stop recording before shutting down.
So reformat the card, copy the video back on, pop it in the CGO3+ and start a new recording?

I've accidentally shut off before stopped recording. I restarted and did what I said above, never lost or had corrupt files. :confused::)
Lucky you :D

If you’ve got a binary editor I wonder if the video file is simply missing an end of file marker if things are not shut down as expected.
What would I have to look for?
 

New Threads

Members online

Forum statistics

Threads
17,120
Messages
200,031
Members
19,805
Latest member
DroneAddict999