Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Engine clogged

Joined
Aug 10, 2018
Messages
12
Likes
2
Age
34
#1
Hello,
is the third time I've used the Breeze, never had any problems before, even was used. Around 1 hour of flight in total.

I put in the grass, and after i turn on, it just come up from one side, finish in the grass from the other side. The error message was "engine clogged" (literary translate from italian "motore otturato".
On of the legs become green, and after the second attempt become red.

How to fix? I can't find a solution in italian faq on the site..
 
Joined
Jul 6, 2018
Messages
617
Likes
322
Location
UK
Website
aerocam.org.uk
#2
Very important not to take off from unsuitable surfaces - always take a landing pad if there is long grass that could get caught in props, or dust that could be kicked up into your motors or gimbal when you launch. Unfortunately, it is a lot harder to get dirt out of motors than it is to get it in. You don't say if the motor is now permanently clogged and non functional, but presumably you cleared any obstructions, rebooted the machine and tried again ?

If you did that and the motor remains dead / you still get the error message and can't fly, your choices are:

1. Remove and disassemble that motor and thoroughly clean it - there are videos online that show you this process, like this one.
2. Order and fit a replacement motor
3. Return the unit for non-warranty repair (they are likely to charge you, as this was pilot error).
 
Last edited:
Likes: thoneter

New Threads

Members online

Forum statistics

Threads
13,782
Messages
156,920
Members
16,463
Latest member
kenfoote