Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Forward flight abruptly stops, for a second or 2

Joined
Mar 9, 2017
Messages
113
Reaction score
28
Location
Burlington VT
I don’t think speed should make a difference. There is nothing flexible in the system that would allow one component or another to change is spatial relationship with another part of the system when forces are applied to the UAV. Thus, if you were to suddenly speed up and the 520 momentarily tips downward, the “space” between the props and the anti collision beam is not going to change. Likewise, the spatial relationship will remain the same if you at half speed or at full speed.
 
Joined
Mar 9, 2017
Messages
113
Reaction score
28
Location
Burlington VT
So after speaking to my friend who also flies a H520 and is also a helicopter pilot I now believe PPldroneuser is likely correct in his conclusion that speed is the stutter stop culprit. My idea that the sensors can't see the props is correct, the spatial configuration between the props and the OA sensors never changes. What the sensors are "seeing" is the prop wash from the props. Hence at slow speeds you don't see stutter stops while at "full speed" with OA on (9 MPH) you do. I went out and flew a couple of batteries after my previous post and tried tried to mimic what PPldroneuser said. And I was able to do just that - I got a bunch of stutter stops until I slowed the 520 down. What my friend suggested doing was go forward at some speed that elicits the stutter stop(s). Then, simple reverse course. The prop wash now seen by the sensors will be further away. If there are no stutter steps we have our answer confirmed. If we still get stutter steps it doesn't rule out the prop wash explanation. Imaya naot get to fly again until early next week. Someone else may get to test the theory before then.
 
Last edited:
  • Wow
Reactions: DoomMeister
Joined
Mar 9, 2017
Messages
113
Reaction score
28
Location
Burlington VT
Good idea, but it will have to wait as he winters in Florida. Doesn’t come back until early to mid May. We shall do some testing then. Stand by. Will report our findings when we get them.
 
  • Like
Reactions: WTFDproject
Joined
Aug 8, 2018
Messages
7
Reaction score
2
Age
49
Mine does this when I have the obstacle avoidance on, almost every time unless I fly nice and slow with it, always thought it was picking up the props. Never thought to check the connection between the drone and controller.
I'm getting a similar stutter or bucking in forward flight with the H520 obstacle avoidance on or in standby modes. But I am also getting an obstacle avoidance alert display on the controller. Flying forward in turtle speed, the obstacle avoidance error does appear to occurs less often. I've cleaned the obstacle avoidance send/receive sensors and tested the sensor's connections but no issues found. The H520 obstacle avoidance sensors are still picking up ghost obstacles. I’m now thinking the sensors have been compromised and may need replacement. Any thoughts to resolve the problem would be appreciated. Thanks
 
  • Like
Reactions: P Howard

New Threads

Members online

Forum statistics

Threads
20,292
Messages
235,104
Members
25,165
Latest member
genesis66