Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Four problems I found in the E90

Joined
Aug 19, 2017
Messages
1,068
Likes
312
#1
Hi

I tell you about the 4 problems I have encountered so far using the E90.

  • As I have already mentioned in another thread, a micro SD card that meets all requirements but does not work. I mention it in the thread Micro SD problem. What Micro SD buy?
  • The MicroSD card stays stuck in the slot from time to time. As if that little spring function that you have to press it exits does not work. I've had to pull it out several times by squeezing hard and using a thin screwdriver and pliers.
  • Having installed the latest version 1.31 of the Gymbal, twice already take off with the camera tilted, with the wrong roll despite being the aircraft completely horizontal. It's only been happening to me since I installed the latest version.
  • The lens frame support, where we screwed the adapter to place a filter, is loose. It looks like it can't be screwed into the base of the camera and I have a feeling it's stuck. Today the first time I put the adapter in place to put a filter and record the snowy landscape it turned everything around and simply pulling out the whole set, it is not necessary to force and it seems that inside it has residue like glue.
Is anyone else going through any of this? What worries me most is the last point. It is not normal for everything to come out so easily, at any moment it could fall.
 
Joined
Dec 6, 2017
Messages
19
Likes
2
Age
60
#2
Hi

I tell you about the 4 problems I have encountered so far using the E90.

  • As I have already mentioned in another thread, a micro SD card that meets all requirements but does not work. I mention it in the thread Micro SD problem. What Micro SD buy?
  • The MicroSD card stays stuck in the slot from time to time. As if that little spring function that you have to press it exits does not work. I've had to pull it out several times by squeezing hard and using a thin screwdriver and pliers.
  • Having installed the latest version 1.31 of the Gymbal, twice already take off with the camera tilted, with the wrong roll despite being the aircraft completely horizontal. It's only been happening to me since I installed the latest version.
  • The lens frame support, where we screwed the adapter to place a filter, is loose. It looks like it can't be screwed into the base of the camera and I have a feeling it's stuck. Today the first time I put the adapter in place to put a filter and record the snowy landscape it turned everything around and simply pulling out the whole set, it is not necessary to force and it seems that inside it has residue like glue.
Is anyone else going through any of this? What worries me most is the last point. It is not normal for everything to come out so easily, at any moment it could fall.
Well we have the H520 and so far so good, have not had any problems that you mention.
WE have flown it in fairly high winds and 400000 volt power lines with no problems, the power lines really surprised me E90 camera works good.
 
Joined
Aug 19, 2017
Messages
1,068
Likes
312
#3
I'm glad to hear it :)

I forgot to mention another problem. The rubber protector on the SD card and the USB port, from the first day it is released, there is no way that it will fit properly in place. I solved it with a little zeal.
 
Joined
Dec 6, 2017
Messages
19
Likes
2
Age
60
#4
I'm glad to hear it :)

I forgot to mention another problem. The rubber protector on the SD card and the USB port, from the first day it is released, there is no way that it will fit properly in place. I solved it with a little zeal.
You have to be gentle with it, but I can see your issue, this is the only thing that will probably not last, that protector is to weak I know eventually it will just break off, oh well a minor issue for me.
 
Joined
Aug 19, 2017
Messages
1,068
Likes
312
#5
You have to be gentle with it, but I can see your issue, this is the only thing that will probably not last, that protector is to weak I know eventually it will just break off, oh well a minor issue for me.
I've been very careful, it's worth a lot of money to make the brute. I just opened it the first day and it didn't close properly anymore. I didn't give it much thought because a little bit of zeal solved it.

Right now I have just glued with cyano the outer metal ring of the lens, the part where the filter adapter is threaded. I don't know, I find it strange that the fence is glued instead of threaded or using another anchoring system.

It is important that we share our experiences so that the people behind us are more careful, even though I have had it myself.
 
Joined
Dec 6, 2017
Messages
19
Likes
2
Age
60
#6
Hmm what do you mean with the "fence" is glued?
Right now I am trying to figure out how to turn of the led lights.
 
Joined
Aug 19, 2017
Messages
1,068
Likes
312
#7
Hmm what do you mean with the "fence" is glued?
Right now I am trying to figure out how to turn of the led lights.
Sorry, it's my bad English and the translator doing his own thing.

The metal piece that surrounds the lens, where you thread the adapter or protector that comes with the camera. In my case, it comes out on its own. Where it says Yuneec and at the bottom the characteristics of the lens. Today, by unscrewing the guard to screw on the adapter and attaching a filter, the entire part has started to turn. Gently pulling out gently exits whole. That piece theoretically shouldn't move or come out. That piece is the one I just pasted.
 
Joined
Dec 6, 2017
Messages
19
Likes
2
Age
60
#8
Sorry, it's my bad English and the translator doing his own thing.

The metal piece that surrounds the lens, where you thread the adapter or protector that comes with the camera. In my case, it comes out on its own. Where it says Yuneec and at the bottom the characteristics of the lens. Today, by unscrewing the guard to screw on the adapter and attaching a filter, the entire part has started to turn. Gently pulling out gently exits whole. That piece theoretically shouldn't move or come out. That piece is the one I just pasted.
yes you are right I looked at mine and it just unscrews, it definitely should not come off.
 
Joined
Aug 19, 2017
Messages
1,068
Likes
312
#9
yes you are right I looked at mine and it just unscrews, it definitely should not come off.
It doesn't really unscrew. It has no thread to be screwed into the body of the camera. I've looked inside and it's got glue-like remains. If you're going to focus the camera upright, it could fall off. It's nice to know it's not just me.

I have glued the piece but only in two opposite points and a micro-drop of cyano nothing else in each point. I imagine that if there is a problem in the future and the camera has to be disassembled, it will be necessary to remove that piece so we must leave that possibility.
 
Joined
Aug 19, 2017
Messages
1,068
Likes
312
#15
OK yes you are right, but that should not come off by itself.
It doesn't make sense, that piece should be fixed. In my case it has started to turn when unscrewing the guard. I pulled out a little bit, without straining, and it came out in one piece. A little glue but very little glue and solved. It's metal, I hope the dilatation doesn't bring the problem back. Knowing that, I'll check it out once in a while.
 
Joined
Aug 19, 2017
Messages
1,068
Likes
312
#17
For now, as far as I know, I'm the first one it happens to. Let's hope it stays that way.

However, knowing that this problem may arise, it is not superfluous for all of us to take into account and make sure that everything is correct.
 
Joined
Jul 30, 2018
Messages
2
Likes
0
Age
55
#19
Hello my brand new E90 has the same problem.... The first time i want to remove the lens it was very hard to unscrew .... now the thread is just ...dead... the lens was not correctly fitted in factory. And the ring is unglued too. Yuneec says they can't send me this ring with the thread. I project to print a new ring and I wait to receive a 39mm thread to fit on my print.
 
Joined
Dec 6, 2017
Messages
19
Likes
2
Age
60
#20
Hello my brand new E90 has the same problem.... The first time i want to remove the lens it was very hard to unscrew .... now the thread is just ...dead... the lens was not correctly fitted in factory. And the ring is unglued too. Yuneec says they can't send me this ring with the thread. I project to print a new ring and I wait to receive a 39mm thread to fit on my print.
Well that is strange I do not have any one of those issues, my H520 has been just fine for the last 7 months.
 

New Threads

Forum statistics

Threads
13,200
Messages
149,949
Members
15,841
Latest member
TheHorta