Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Gimbal issues after a repair

Joined
Oct 23, 2017
Messages
64
Reaction score
19
Age
58
Location
Rahan, Co.Offaly, Ireland
My H520 is suffering from the dreaded auto tilt while flying. All calibrations have been carried out, successfully, except for the gimbal one. It gets to about 35-40% and then just hangs. Any ideas please people?

Thank you
 

arruntus

Premium Pilot
Joined
Aug 19, 2017
Messages
1,579
Reaction score
532
I don't know, have you tried resetting the camera and putting the firmware from 0?
 
Joined
Oct 23, 2017
Messages
64
Reaction score
19
Age
58
Location
Rahan, Co.Offaly, Ireland
I have carried out everything in my power Arruntus but the gimbal keeps hanging when I start the calibration.
 
Joined
Dec 26, 2017
Messages
80
Reaction score
52
Location
Stockton, California
My H520 is suffering from the dreaded auto tilt while flying. All calibrations have been carried out, successfully, except for the gimbal one. It gets to about 35-40% and then just hangs. Any ideas please people?

Thank you
Just a hunch but are you starting the gimbal calibration with the setting for tilt in the center position on your controller?
 
  • Like
Reactions: Addison

arruntus

Premium Pilot
Joined
Aug 19, 2017
Messages
1,579
Reaction score
532
You are not the first to report the same problem, I told you the camera, but the one that initiates the procedure is the DataPilot, the same is the application you have to reinstall from 0, I do not know, to try, you do not lose anything.
 

John Hennessy

Premium Pilot
Joined
Jun 26, 2017
Messages
233
Reaction score
166
Age
62
Is there a YUNEEC DOCTOR that can prescribe a medication to help this 520 with a hanging gimbal. Paint it blue and tell it that it is viagra and the placebo effect should work.
No in all seriousness Addison, I am sorry to hear this and it seems that it may need a trip to the specialists at YUNEEC. Are all the slip ring wires in good shape or worn on the insulation edge as that would give off E I and may show up on the sensor. I don't know but it may be worth a check to see.
Johnno Hennessy.
Keep Flying on the Green side of the GRASS.
 
  • Haha
Reactions: Addison
Joined
Oct 23, 2017
Messages
64
Reaction score
19
Age
58
Location
Rahan, Co.Offaly, Ireland
Is there a YUNEEC DOCTOR that can prescribe a medication to help this 520 with a hanging gimbal. Paint it blue and tell it that it is viagra and the placebo effect should work.
No in all seriousness Addison, I am sorry to hear this and it seems that it may need a trip to the specialists at YUNEEC. Are all the slip ring wires in good shape or worn on the insulation edge as that would give off E I and may show up on the sensor. I don't know but it may be worth a check to see.
Johnno Hennessy.
Keep Flying on the Green side of the GRASS.
That made me laugh. I would do all the above but after resetting the ST16 I now find that I have the wrong password when attempting to connect to the E90, it's lucky I'm patient!

UPDATE: Sorted the password issue out and reset everything. After conducting the umpteenth gimbal calibration I have detected a slight judder immediately before it hangs. It's now all packaged up and ready to be sent back to the suppliers in the UK as it's still under the two year warranty period and hopefully it is an issue with the gimbal and not something I have done.

Will keep you posted.
 

New Threads

Forum statistics

Threads
15,660
Messages
182,402
Members
18,290
Latest member
i7wjrng4