Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

H520 ST16 Controller Update seems to have KILLED my ST16. HELP!

Joined
Nov 3, 2019
Messages
31
Reaction score
18
Age
59
Well...I started this evening having issues with Wifi when trying to do Software Update. Got that fixed. Got through ALL of the updates except the final one for the Controller...did that one...and now...the ST16 seems dead...blue power light is on...screen is black. (Sorry I don't recall the actual update name/version...I think it was the 2nd one listed for the controller.

Any ideas? Is there a link I can go to to download a fix, OS, magic bullet, etc. onto an SD card and manually restore/reload?
 

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
8,012
Reaction score
4,460
Location
Bessemer, MI
First thing to try: Remove the battery, wait several min then reinstall and see if it will power up.
 
Joined
Nov 3, 2019
Messages
31
Reaction score
18
Age
59
First thing to try: Remove the battery, wait several min then reinstall and see if it will power up.
Thanks for the quick response and suggestion.


Alas didn’t help. At power up the blue light comes on, the fan starts, and after about 20 to 30 seconds the “Yuneec Electric Aviation” splash screen appears. It stays there about 10 seconds then the fan shuts off and the screen goes dark/blank...dead (except the blue power light is still on)
 
  • Sad
Reactions: Steve Carr

Murray Martz

Moderator
Staff member
Premium Pilot
Joined
Jan 29, 2017
Messages
1,212
Reaction score
647
Location
Saskatchewan, Canada
Thanks for the quick response and suggestion.


Alas didn’t help. At power up the blue light comes on, the fan starts, and after about 20 to 30 seconds the “Yuneec Electric Aviation” splash screen appears. It stays there about 10 seconds then the fan shuts off and the screen goes dark/blank...dead (except the blue power light is still on)
Remove any micro SD card that may be in it and try again. Also, remove the battery and slide the power button to the on position. After about 30 seconds slide the power button to the off position, put the battery back in and try again. With the battery out and the power button on, it will discharge any residual power that may be causing an issue.

Another thing to try after all of that, is plug it into your PC with the power button in the off position, then turn the power on the ST16 back on and see if the PC recognizes it.
 
Last edited:
  • Like
Reactions: Mike Irish

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
8,012
Reaction score
4,460
Location
Bessemer, MI
After powering it on tap the center button below the screen repeatedly and see if you get a menu to pop up.
 
Joined
Nov 3, 2019
Messages
31
Reaction score
18
Age
59
Remove any micro SD card that may be in it and try again. Also, remove the battery and slide the power button to the on position. After about 30 seconds slide the power button to the off position, put the battery back in and try again. With the battery out and the power button on, it will discharge any residual power that may be causing an issue.

Another thing to try after all of that, is plug it into your PC with the power button in the off position, then turn the power on the ST16 back on and see if the PC recognizes it.
Thanks for the response Murray. 1) no micro SD card in the unit. 2). same result - power light comes on...fan starts...splash screen displays...screen goes dark, fans stops, but blue power light still on. 3). I'm at my "day" job and don't have my USB cable for the ST16 with me. Will grab it after my 9am CT meeting (I know I've hooked the ST16 up to the computer before to download logs...I'm Mac based)
 
Joined
Nov 3, 2019
Messages
31
Reaction score
18
Age
59
After powering it on tap the center button below the screen repeatedly and see if you get a menu to pop up.
Continued thanks Steve. Unfortunately can't get a menu...started pressing the center button as soon as I saw the Yuneec splash screen...no menu...unit still goes "dark" after about 15 to 30 seconds (blue power light still on...unit dead)
 
Joined
Nov 3, 2019
Messages
31
Reaction score
18
Age
59
Re-asking an earlier question (after talking with an Android guy here at my day job). IS there anywhere (i.e., a link) that I can go and download a Firmware/Flash fix to a microUSB card, boot the ST16 from that...and repair the issue. My Android guy said it sounded like a case of the upgrade not completing and hosing the OS
 
Joined
Jan 21, 2020
Messages
1
Reaction score
0
Age
35
After powering it on tap the center button below the screen repeatedly and see if you get a menu to pop up.
You have to tap several times on the center softbutton until the system is started. Not hold the button. I had have the same Problem with our ST16S
 
Last edited by a moderator:
Joined
Nov 3, 2019
Messages
31
Reaction score
18
Age
59
Thanks for the response Murray. 1) no micro SD card in the unit. 2). same result - power light comes on...fan starts...splash screen displays...screen goes dark, fans stops, but blue power light still on. 3). I'm at my "day" job and don't have my USB cable for the ST16 with me. Will grab it after my 9am CT meeting (I know I've hooked the ST16 up to the computer before to download logs...I'm Mac based)
Hello again Murray. Was able to grab my cord and try hooking to the Computer (Mac). Still no joy. It acts like its trying to begin charging the battery (white battery icon flashes in the middle of the display)...but nothing every mounts to the computer desktop
 
Joined
Oct 5, 2018
Messages
5
Reaction score
0
Age
62
Allumez la radio et tapotez le plus vite possible sur le bouton programmable central jusqu'à ce qui y est ecrit YUNEEC sur l'ecran
 
Joined
Nov 3, 2019
Messages
31
Reaction score
18
Age
59
You have to tip several times on the center softbutton until the system is started. Not hold the button. I had have the same Problem with our ST16S
Thanks for the suggestion Flo. Question...what are you calling the center "soft button". I've tried all three buttons (the "center" button that looks like a mini menu, the home button (looks like a house), and the "return" button that looks like a letter U on its side with the arrow on top pointing left). Have "tapped" (?) several times on each...during the splash screen and after the unit "goes dark". Still nothing. Thoughts? What am I doing wrong?
 
Joined
Nov 3, 2019
Messages
31
Reaction score
18
Age
59
Allumez la radio et tapotez le plus vite possible sur le bouton programmable central jusqu'à ce qui y est ecrit YUNEEC sur l'ecran
YUREKA!. I think you were basically saying the same as Steve/Flo...I just wasn't tapping the center button soon enough...started immediately AFTER turning on the power switch. Eventually it DID reboot. Testing everything now
 

h-elsner

Premium Pilot
Joined
Mar 23, 2016
Messages
1,199
Reaction score
845
Location
Bavaria / Germany
The ST16 has a small push button behind the earphone jack. When you press this button, hold it (i.e. with a tooth pick) and switch on the ST16 then you get into the fastboot mode of Android. This is the moment where the Android guy has to take over.
I guess it's the same for ST16S but I'm not sure.

br HE
 
  • Like
Reactions: Steve Carr
Joined
Nov 3, 2019
Messages
31
Reaction score
18
Age
59
The ST16 has a small push button behind the earphone jack. When you press this button, hold it (i.e. with a tooth pick) and switch on the ST16 then you get into the fastboot mode of Android. This is the moment where the Android guy has to take over.
I guess it's the same for ST16S but I'm not sure.

br HE
Thanks! I shall make note of that in my ever building documentation for this bird. It seems ALL is good again.
 
Joined
Nov 3, 2019
Messages
31
Reaction score
18
Age
59
UPDATE: After the MUCH appreciated help on this site (you folks are the best) I am now in business again. I'll certainly document all of this for the "future" in case such happens again. Thanks again to everyone who responded.
 
Joined
Oct 27, 2020
Messages
4
Reaction score
4
Age
34
The ST16 has a small push button behind the earphone jack. When you press this button, hold it (i.e. with a tooth pick) and switch on the ST16 then you get into the fastboot mode of Android. This is the moment where the Android guy has to take over.
I guess it's the same for ST16S but I'm not sure.

br HE
Since no one provided a guide... you don't really need to get into fastboot mode via toothpick to fix this...

To put the controller into recovery mode you'll need to download the google android SDK, among other things as I learned last night.

  1. Make sure you use a data USB cable as the one that comes with your drone is power only. (30 minutes of my life I wish I had back.)
  2. Download the Android SDK. Download Android Studio and SDK tools | Android Developers
  3. Install Google Drivers from the SDK. Get the Google USB Driver | Android Developers
  4. Install the SDK Platform Tools. SDK Platform Tools release notes | Android Developers
  5. Next take the update.zip file that the initial post in this thread had you create or download and drop it into the platform-tools folder (screenshot.)
  6. Plug your ST16S into your machine, turn it on and wait for it to recognize.
    • If it doesn't make sure you've installed the Google drivers from the SDK. If it's still not being recognized you may want to uninstall the device from device manager and try unplugging and plugging it back in.
  7. After that's complete hold shift and right click in the platform-tools folder, from there you'll have the option to open a command prompt or power shell if you're on windows 10. (screenshot)
  8. Once powershell is open type "ADB Devices" you should see something listed. (Screenshot)
  9. If your device is listed and you have the update.zip in the same folder type "ADB Sideload update.zip" without the quotes. You should see it start to push the zip to the device.
  10. After pushing to the device the OS will reinstall and update, give it about 5 minutes. It may linger on the splash screen a bit but don't get discouraged.
  11. After the OS re-installs if you had the app crashing problem you're still going to have that problem, this is because the program resides in a different part of the internal storage. You'll need to tap the center button repeatedly during boot to get to the main android screen at which point you should follow the instructions at the start of this thread. Bricked ST16s Recovery
  12. Side note: If you wipe this device from the fastboot/Recovery menus the way you select "with the power button" is kind of stupid... it doesn't register the power switch as being off when it's in the off position so the way you select items is by turning the switch to the on position for a few seconds then flipping it back to off. Also scrolling with the + and - signs... you don't tap them you swipe them up and down.
This was 5 hours of work to figure out, but should only really take about 30 minutes to complete.

Good luck!
 

Attachments

  • 2020-10-28 (1).png
    2020-10-28 (1).png
    16.7 KB · Views: 7
  • 2020-10-28.png
    2020-10-28.png
    162 KB · Views: 7

New Threads

Forum statistics

Threads
19,495
Messages
226,093
Members
23,088
Latest member
robert1k