Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Motors not idling when landing

Joined
Nov 2, 2016
Messages
13
Reaction score
1
Age
54
New to Typhoon H ownership, though I have test flown one before. All seems fine with mine, apart from one issue. When landing, it's a little bouncy, but not too bad. More importantly, the motors don't go to idle when it's on the surface and the left stick fully down.
This means that it begins to hop and could have a roll over. i picked it back up to a hover and tried with the 'home' switch, same issue.
By killing the motors as soon as it touched down, I could land it successfully, otherwise I'd have been grabbing it!
Latest firmware for everything installed, plus a successful calibration of Accelerometer and compass just today, as far as I can tell. It's Realsense equipped, but that was selected off.
Could this be a barometer / altimeter / Realsense issue?

Any other things I should be looking for?

Thanks

Neill W
 
Joined
May 10, 2016
Messages
1,646
Reaction score
681
Age
64
Location
Melvin Michigan, In the thumb
Check the calibration of your ST-16 Here is the link.
ST-16 Calibration ( secret menu )
Your left stick may not be going 100% in the down postion. I had same issue and calibrating the ST-16 solved it by doing the calibration. You MUST make sure your rabbit/turtle and the camera tilt sliders are in the middle BEFORE you start. there is also a Youtube video at:
 
  • Like
Reactions: zandoli
Joined
Oct 10, 2016
Messages
29
Reaction score
10
Age
71
Location
Kingsport, TN
This behavior is in keeping with conflicts with compass calib and accelerometer
Redo both of these till the behavior isn't there
The typhoon IMU can't tell when it's both level and at ground level so it hops
 
Joined
Nov 2, 2016
Messages
13
Reaction score
1
Age
54
Thanks, guys, will try both of those. It's just had all the firmware updated, so perhaps calibration needs more attention from me.

Neill W
 
Joined
Jun 1, 2016
Messages
55
Reaction score
17
Age
64
I had the same problem after doing the update. After compass cal and accelerometer it flew around perfect. Went up to around 200 feet to take some videos for a while. Brought it back down and landed with no problem, did some more flying around and all of a sudden it wanted to go it's own way and toilet bowling pretty bad. Went to land but it didn't want to. I could get it to the ground but the motors wouldn't idle. Tipped over just before I shut down the motors. I have no idea why this happened. I will try it again tomorrow keeping it close to the ground at first untill I see how it flys. If it still doesn't fly good I'll do the calibrations again.
 
Joined
Nov 2, 2016
Messages
13
Reaction score
1
Age
54
I had the same problem after doing the update. After compass cal and accelerometer it flew around perfect. Went up to around 200 feet to take some videos for a while. Brought it back down and landed with no problem, did some more flying around and all of a sudden it wanted to go it's own way and toilet bowling pretty bad. Went to land but it didn't want to. I could get it to the ground but the motors wouldn't idle. Tipped over just before I shut down the motors. I have no idea why this happened. I will try it again tomorrow keeping it close to the ground at first untill I see how it flys. If it still doesn't fly good I'll do the calibrations again.
Mine's ben fine today apart from the motor idling issue. I guess I might need to throw a spirit level into the back pack, as I'm reading that they're critical on being very level for accelerometer. It's like setting up a racing car :)
 
Joined
Aug 2, 2016
Messages
126
Reaction score
52
Mine's ben fine today apart from the motor idling issue. I guess I might need to throw a spirit level into the back pack, as I'm reading that they're critical on being very level for accelerometer. It's like setting up a racing car :)
Hi Mike... I saw a great calibration tip on here. I tried it using a spirit level but placed it lightly on the motor housing and not the landing gear. The post is in the listings.. something like 'Perfect Calibration'... take a look.. maybe page 2.. It worked well for me.
Cheers.
Chris.
 
  • Like
Reactions: MikeB
Joined
Jun 1, 2016
Messages
55
Reaction score
17
Age
64
Hi Mike... I saw a great calibration tip on here. I tried it using a spirit level but placed it lightly on the motor housing and not the landing gear. The post is in the listings.. something like 'Perfect Calibration'... take a look.. maybe page 2.. It worked well for me.
Cheers.
Chris.
Thanks Chris,
I'll give it a go tomorrow and see if it makes a difference.
 
  • Like
Reactions: Christoph

New Threads

Forum statistics

Threads
17,105
Messages
199,855
Members
19,797
Latest member
1128retromod