Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

New typhoon H owner from Missouri.

Joined
Aug 13, 2019
Messages
15
Reaction score
7
Age
50
Hello all, I purchased a used Typhoon H Pro about a week ago. really liking it so far except video range is only about 100 feet. I switched over to the flat antenna and it hasnt really fixed the problem. also the camera begins to tilt every now and then. I have to land and do a complete system restart to clear it.
 
Joined
Jul 4, 2017
Messages
4,158
Reaction score
1,921
Age
63
Location
Ocoee, Florida
Welcome.
The flat antenna needs always pointed to the H, Mushroom antenna not so.
Try re-calibrating the camera on level ground for the tilt problem.
100 feet? hmmm others have to chime in on this?
here's the latest manual for the H, If you don't already have one.
 

Attachments

Joined
Aug 13, 2019
Messages
15
Reaction score
7
Age
50
thanks, yea its kinda strange, I just read on here where another person had range problems and turned out being a broken wire leading to the antenna mount.
 
Joined
Aug 13, 2019
Messages
15
Reaction score
7
Age
50
I tried the mushroom antenna first then swapped out for the square patch antenna, cleared up some of my twitchy video problems. but range is still questionable.
 
Joined
Jul 4, 2017
Messages
4,158
Reaction score
1,921
Age
63
Location
Ocoee, Florida
I've been flying well over 2 years (92 hours) and only once used the flat antenna.
 

FlushVision

Premium Pilot
Joined
Jun 19, 2016
Messages
2,973
Reaction score
1,287
Age
64
Location
Shaw, Gtr Manchester, U.K.
I've been flying my TH for over 3 years exclusively using the mushroom antenna...I don't have a patch antenna. I know that I have a video range of at least 500mtrs (legal maximum to fly out is 500mtrs in the U.K.) using the mushroom so I can say that you definitely have a problem...but of course you already know that.

Look for broken wires to the camera, a depressed pin on the shoe, or an improperly secured mushroom or patch antenna on the ST16. The antenna for video at the camera (aircraft) side is situated within the camera shell itself...below the sensor towards the front of the shell.
 
  • Like
Reactions: Clayton B.
Joined
Aug 13, 2019
Messages
15
Reaction score
7
Age
50
update just checked the antenna wire connection inside the st16. the connection was good and taped, I did remove the wire and tested with meter. wire is good. also I did find a loose main connection to the 5ghz board, the small white plug with a bundle of ketchup and mustard wires. fixed that then replaced cover. tested with mushroom antenna, gets better range now.
 

FlushVision

Premium Pilot
Joined
Jun 19, 2016
Messages
2,973
Reaction score
1,287
Age
64
Location
Shaw, Gtr Manchester, U.K.
update just checked the antenna wire connection inside the st16. the connection was good and taped, I did remove the wire and tested with meter. wire is good. also I did find a loose main connection to the 5ghz board, the small white plug with a bundle of ketchup and mustard wires. fixed that then replaced cover. tested with mushroom antenna, gets better range now.
What sort of range are you getting now?
 
Joined
Aug 13, 2019
Messages
15
Reaction score
7
Age
50
considering I did a ground test, open view. Im getting a bit over 600 feet.
 
Joined
Aug 13, 2019
Messages
15
Reaction score
7
Age
50
I tested with a rubber ducky antenna I had laying around and still getting about 600-700 feet.
im happy with that for now.
gonna test after dinner for interference. I just realized we have a wifi extender that broadcasts in 2.4 and 5.8ghz. we dont use the 5 ghz bandwidth.
 

New Threads

Members online

Forum statistics

Threads
17,113
Messages
199,954
Members
19,802
Latest member
Bandit