Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

No Network Connection on my cgo3 camera.

Joined
Apr 24, 2019
Messages
18
Reaction score
1
Age
51
My camera says no network connection when hooked up to the handheld, and does not connect when hooked up to the drone. Anyone know of a fix?
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
1,817
Reaction score
1,219
Location
North Carolina Piedmont, USA
Also, look at the small light on the camera ball to the upper left of the camera lens. What colors, patterns is it flashing?

CGo3 Codes2.PNG
 
Last edited:
Joined
Apr 24, 2019
Messages
18
Reaction score
1
Age
51

Attachments

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
1,817
Reaction score
1,219
Location
North Carolina Piedmont, USA
Nope. Sounds like there is no power to the camera section. Does the gimbal itself have power and lights on the gimbal board? Or maybe even stabilize?
 
Joined
Apr 24, 2019
Messages
18
Reaction score
1
Age
51
Nope. Sounds like there is no power to the camera section. Does the gimbal itself have power and lights on the gimbal board? Or maybe even stabilize?
No indication of having any kind of power. No stabilization or lights of any kind.
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
1,817
Reaction score
1,219
Location
North Carolina Piedmont, USA
We need to understand the history of the camera. Mainly, have the three black wires that run from the top hotshoe connector to the gimbal board ever been pulled loose, or are they pulled loose now?
 
Joined
Apr 24, 2019
Messages
18
Reaction score
1
Age
51
We need to understand the history of the camera. Mainly, have the three black wires that run from the top hotshoe connector to the gimbal board ever been pulled loose, or are they pulled loose now?
I bought this drone off Ebay. It was sold as is with no history of why it did not work. The drone I bought worked perfect after I updated the firmware, but the camera never connected. I took a camera from another q500 and attached it. It paired and worked perfectly. I also tried hooking the defective camera to a different q500 with the same results, no connection. The drone has no indication of ever having been flown, let alone crashed. I truly believe this drone was a return item and had never been flown. Every piece in the box appeared to be brand new, even the camera that doesn't work.
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
1,817
Reaction score
1,219
Location
North Carolina Piedmont, USA
Sounds like one of the eBay series that got sold by one seller, ranging from $99 to $149? I bought the $99 one, and it was great.
But to your problem, we have to figure out where the power loss is. Take the four rubber dampers apart, then check if the three black wires at least seem to ALL be connected at both ends.

How technically inclined are you? None of this is going to be rocket science, but it might sound like it if we aren't speaking the same tech language. I'm kind of an amateur, but I've messed with a lot of the CGo3 stuff.
 
Joined
Apr 24, 2019
Messages
18
Reaction score
1
Age
51
Yes, all three are completely attached. However, yes it was the $149 drone. And yest it works great, except for the camera. On another note, my camera that does work, all of the wires are broken, and I use the pigtail connector for it. Should I try this "intact camera" without the pigtail inserted?
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
1,817
Reaction score
1,219
Location
North Carolina Piedmont, USA
Bad news they are all connected. IF you are absolutely sure none of the wires are loose and might pose a short circuit issue, then yes, try the pigtail. Not sure if you meant you had already tried it.
 
Joined
Apr 24, 2019
Messages
18
Reaction score
1
Age
51
When I flew my first q500, the camera connected without the pigtail, and I only needed the pigtail for the handheld device. But now that the wires have been broken, it must have the pigtail to function. Found this out through research. If the wires become broken, use the pigtail. SO, since my first drone worked without the pigtail, should I try this drone WITHOUT the pigtail.
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
1,817
Reaction score
1,219
Location
North Carolina Piedmont, USA
You can unplug the pigtail. It does the same thing as the hotshoe (assuming the hotshoe has power to it). Since your other camera only has pigtail functioning, I guess we can not yet rule out a bad hotshoe, but that would just be a second issue to address later The main issue at the moment is "the gimbal board has a power input problem".
 
Joined
Apr 24, 2019
Messages
18
Reaction score
1
Age
51
The hot shoe is fine, as the good camera came off of that drone and worked fine without the pigtail before I broke the wires in a crash. So, I believe your assessment of no power in the camera is spot on.
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
1,817
Reaction score
1,219
Location
North Carolina Piedmont, USA
There are a couple things that sometimes recover this problem. If you want to check, there is at least ONE that maybe does not require tools. A multimeter would be great if you have one available.
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
1,817
Reaction score
1,219
Location
North Carolina Piedmont, USA
I should be around tomorrow. I'll try to find some good pics of what you can look for. Give me a shout when you want to work on it.
What part of the country (i.e., time zone) are you in?
 
Joined
Jan 6, 2016
Messages
135
Reaction score
36
Age
65
My camera says no network connection when hooked up to the handheld, and does not connect when hooked up to the drone. Anyone know of a fix?
I had a power problem to one of my drones a while back... thought it was the camera but ended up to be the tiny circuit card right inside the drone itself that the pigtail plugs in to...
 

New Threads

Forum statistics

Threads
18,171
Messages
212,879
Members
21,072
Latest member
Tri-Dee Farms Ltd.