Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Possible trouble with the K3 slider indication...

Joined
Jun 7, 2016
Messages
232
Reaction score
38
Age
84
Location
Near Seattle, WA
I recently sent my Typhoon H & St16 in for repair. When I got it back, I was checking all the controller levers, switches, joy sticks, etc. This was in the Hardware Monitor screen. All controls were normal except when I checked the K3 slider control for the Rabbit/Turtle movement. When I slid it all the way up, the indication showed all the way up. But when I moved it all the way down, the indication stopped in the middle of the display.
I called Yuneec about this, but they didn't have an answer. I'm pretty sure it used to show all the way up AND down before I sent it in. Anyone else have this happen. I haven't installed the latest firmware upgrade yet, so that's not part of this problem yet.
 
Joined
Jun 8, 2016
Messages
872
Reaction score
353
Age
70
You should be able to recalibrate it using the hidden calibration menu.
 
Joined
May 18, 2016
Messages
98
Reaction score
27
Age
39
Were the sliders centered when calibrating the ST16? If not, redo calibration with them centered.

 
Joined
Jun 7, 2016
Messages
232
Reaction score
38
Age
84
Location
Near Seattle, WA
Ok, that worked! What part of my problem was, is that the Tech at Yuneec did not do the first part of the test where you have the seven red squares. We did put the sliders in the middle position, but by skipping the first part of the test, it didn't change the K3 slider so it would move clear to the top and bottom. Now it does!
Thanks for the help. If I knew the last name of the Tech at Yuneec, I would send her an email telling how it's really done!
 
  • Like
Reactions: zandoli

New Threads

Members online

Forum statistics

Threads
17,133
Messages
200,270
Members
19,815
Latest member
CRS