Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Q500 4K moving right when sticks centred

Joined
May 14, 2016
Messages
26
Reaction score
4
Age
62
I there a calibration for the ST10+ , as title my Q500 is drifting non stop slowly to the right with sticks centred , when checking hardware page on the ST I can see the stick is showing a reading that would make the Q not stay in position on a hover , but I cant find a way to calibrate the controller .

Thanks
 
Joined
Oct 1, 2015
Messages
241
Reaction score
172
Location
Ontario, CA
Hi Uptowndisco,

You may try calibrating accelerometer to stop drifting issue. 1:30 mark in this video

Make sure machine is on a flat level surface.

 
Joined
May 14, 2016
Messages
26
Reaction score
4
Age
62
Hi Uptowndisco,

You may try calibrating accelerometer to stop drifting issue. 1:30 mark in this video

Make sure machine is on a flat level surface.

I dont think its craft calibration even the flight sim does the same as flying for real with the Q500

does this in Angle mode so not in a safe circle , I found how to calibrate the sticks through a Ytube video , but
even after calibration it still does this , it is like the centre position is off as I can see the centre number changing
when monitoring in the hardware monitoring page on the controller.

same in Flight Sim, it is like it needs Trim , but the trims do nothing on the ST10
 
Joined
Oct 1, 2015
Messages
241
Reaction score
172
Location
Ontario, CA
You may calibrate your throttle and cyclic stick. If you need additional assistance please call our tech support department at 1-844-898-6332.

 
Joined
Apr 25, 2016
Messages
6
Reaction score
0
Age
72
During calibration of my ST10 + due to a right drift problem, I noticed the J4 box failed to calibrate, while all other functions were successful. I believe the J4 has to do with the right hand toggle which may be causing the drift right problem.
Does anyone know what the trouble is and how to correct it so it does complete the calibration? Is it a defective right toggle?
 
Joined
Sep 28, 2015
Messages
411
Reaction score
98
Age
61
Location
Crossville, Tn - East Tennessee
I had a slight problem with this. I took some canned air and blew out the dust while moving the stick. Problem was solved. Some on here had gone as far as to disassemble the st10 and cleaning it.
 
Joined
Apr 25, 2016
Messages
6
Reaction score
0
Age
72
Thanks! I took the ST10+ apart and blew everything out. Did find a few tiny pieces of grass inside. Then I did the calibration and it corrected.
Thank you for the suggestion!
 

New Threads

Forum statistics

Threads
16,658
Messages
194,215
Members
19,331
Latest member
Grumpy Old Man RC