Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Q500 4k: my experiences with the "tilting camera" phenomenon

Joined
Jun 5, 2018
Messages
4
Reaction score
4
Age
54
Hi All!

I've searched thru these forums and on google on how to remedy the titling (leaning) camera. It sure seems like a common issue: crank up the controller, crank up the quad, get connected and lift off. Everything is fine until you pan left and right (yaw movements) and realize as you pan farther left (or right) the horizon gets more and more crooked. It's a total buzz-kill! LOL. You have to land and reset the controller and quad off and then back on. *Sometimes* that results in a good flight for the rest of the current battery.

So many things I have tried, some kind of work, some not at all. I have two Q's and they both were doing it. The best remedy (hack) I found was: turn on the controller before turning on the aircraft, disconnect the camera. Then turn on the drone. Once the controller connetcs to drone and the full GPS satellites are found, turn both off and then back on. I'd say about 80% f the time that gets it done for the rest of the flight on your current battery. Sometimes it wouldn't help at all.

...then I read on a thread here that one fella claimed it only happened on one of his two batteries. One of his batteries had the issue every time, but he said battery #2 never had the issue. WEIRD.

It did the nasty titling for me on both of OEM batteries...however both had begun to puff up a little bit 6 months or so... I thought about getting another battery and finally did: the Gifi 7500mAh (3rd party battery). Now, I knew I was taking a serious risk by buying that model (50% of reviews say it's crap, 50% claim great luck with them). When it arrived (40% charged), I charged it up and took it out. FIrst of all, the flight was 22 minutes...and I've NEVER, EVER gotten 22 minutes on a Q500, regardless of any battery...I have always averaged 12-13 minutes. BUT HERE'S THE KICKER: no tilt at all! Nothing! 12 flights now on the new GiFi battery and it's been perfect. I put either of my OEM batteries in, launch and it's back to the titling. Land, put the GiFi back in and problem solved! The behavior is the same on both of my Q's. That seems like I might have found something worth seriously considering: it's the batteries that cause it. Worn down and out batteries!

Now, I have heard the rubber dampers on the gimbal wear out and the camera will have more "give" on either the right or the left side of the gimbal and the quad tries to adjust automatically to get the camera level again. Not sure if there's anything to back that up - but, for me, the new battery did it.

One last trick- the 45-degree tilt....you tilt the drone backwards to where it rests on it's rear end. Then turn on the controller, then the drone. Once it connects and is ready for launch, put the drone level for about 20-30 seconds and then launch. That one never worked out for me.

Anyways, thank for reading and just wanted to share is all. LONG LIVE THE Q500! :D
 
Last edited:

New Threads

Members online

Forum statistics

Threads
20,612
Messages
237,860
Members
26,055
Latest member
Erciyes