Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Question about controlling the CG04 camera

Joined
Apr 17, 2018
Messages
120
Reaction score
58
Age
64
Location
Chesapeake, VA
I've been using my 920+ for about 2 months now and the video seems to be fine and it takes great pictures in automatic. When I switch to manual, shutter priority, or aperture priority on the picture side, the St16 screen doesn't change when I change either parameter. I only seem to have control when I'm in one of the automatic modes and manually change the exposure value. I think the values in the camera are changing and the pictures reflect it (need more testing), but the screen isn't updating the changed values which makes it difficult to select, especially in low light. All modes seem to work, as expected for video though.

Am I missing some setting or is this something normal for these cameras?
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
7,357
Reaction score
4,236
Location
Genesee, MI USA
Do you mean the image you see is not changing or the values for aperture, shutter speed , etc. are not staying at the value you set?
 
Joined
Apr 17, 2018
Messages
120
Reaction score
58
Age
64
Location
Chesapeake, VA
The image on the screen is not changing when I change aperture, or shutter speed. This only occurs in picture modes and seems to work fine in the video modes. I believe it's changing in the camera, but not on the screen.


Update: I just did a little more testing. The camera settings are changing and the pictures come out with modified values. The screen of the controller just isn't changing with the parameters which makes the settings a guessing game.
 
Last edited:

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
8,254
Reaction score
4,733
Location
Bessemer, MI
I would expect the aperture to change the visual display. Apparently the aperture setting is only applied when the photo is taken and then opens again.
 
  • Like
Reactions: DoomMeister

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
7,357
Reaction score
4,236
Location
Genesee, MI USA
An SLR does the same thing. They usually have a manual button that allows you to see the screen with the aperture closed to the setting that is selected.

From the original post I think I understood that in video mode of operation the changes in aperture can be seen in the display, but when in photo mode the changes do not affect the display.

I think this is normal behavior. My DSLR cameras do the same thing.

Are you able to display a histogram to evaluate before taking the shot?
 
  • Like
Reactions: Steve Carr
Joined
Apr 17, 2018
Messages
120
Reaction score
58
Age
64
Location
Chesapeake, VA
The histogram doesn't change with changes in settings either. There is really no way to check the light except by switching to video mode.
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
7,357
Reaction score
4,236
Location
Genesee, MI USA
The histogram doesn't change with changes in settings either. There is really no way to check the light except by switching to video mode.
That is likely the case in full manual mode.

If you select aperture priority or shutter priority and then change the EV setting do you see a change on the camera feed?

I think with the CGO4 you can select a spot to adjust the exposure for by touching the screen. I think there is a setting for average , center, and spot for Exposure Value.
 
Joined
Apr 17, 2018
Messages
120
Reaction score
58
Age
64
Location
Chesapeake, VA
That is likely the case in full manual mode.

If you select aperture priority or shutter priority and then change the EV setting do you see a change on the camera feed?

I think with the CGO4 you can select a spot to adjust the exposure for by touching the screen. I think there is a setting for average , center, and spot for Exposure Value.
Yes, if you select aperture priority or shutter priority and change the EV setting the camera feed does change...but the settings, shown on the screen, don't. The only reason I worry about this stuff is because I use it at and before sunrise a lot and motion blur from auto settings can be quite annoying. Auto settings during the daytime, with small ev changes, make for some amazing pictures, especially panaramas. My other drones have significant barrel distortion (especially the P4 pro), which makes them more difficult to work with.
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
7,357
Reaction score
4,236
Location
Genesee, MI USA
We’re you able to find the setting for spot exposure? That may be a solution for golden hour shoots.

If you are getting motion blur, try going to shutter priority to keep a shutter speed that will avoid blurring. Then adjust aperture (and ISO if necessary) to get desired exposure.

Do you bracket and use HDR in post?
 
Joined
Apr 17, 2018
Messages
120
Reaction score
58
Age
64
Location
Chesapeake, VA
I've gotten some pretty decent bracketed photos, but the time it takes to change EV values to do it usually means I have to only do it wide angle.
 

Attachments

  • Y7690045.jpg
    Y7690045.jpg
    8.6 MB · Views: 5
  • Like
Reactions: DoomMeister

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
7,357
Reaction score
4,236
Location
Genesee, MI USA
Very nice!

Check you settings menu. I thought I remembered seeing auto bracket in the CGO4 settings menu when I was as exploring the FlightMode app for the H480/H920+ on the ST16.
 
Joined
Apr 17, 2018
Messages
120
Reaction score
58
Age
64
Location
Chesapeake, VA
I seem to remember it for the H480, but I can't find it for the 920. There are three "burst modes" in the drive menu. Is it possible I have the wrong or mismatched firmware?
It looks just like what another member showed in another thread though.
 
Last edited:

New Threads

Members online

Forum statistics

Threads
20,292
Messages
235,104
Members
25,165
Latest member
genesis66