Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

ST-16 CONTROLLER discharges the battery

Joined
Jun 17, 2019
Messages
13
Reaction score
5
Age
72
Hello everyone,

Taking the opportunity of this is a place where everybody helps each other, I would like to ask for your help for the following:

I have an typhoon H, and the problem in my ST-16 CONTROLLER discharges the battery (not the drone) that it uses even when
it's being turned off. I thought the battery was having a problem and I installed a new battery and the problem continues.

At the top right in the Battery level icon indicates this symbol tool perhaps meaning that a repair needs to be done.

I had never encountered this problem before, everything was going well until now.

The battery recharges without problem. When the battery is charged and the ST-16 is turned on everything works fine.

Any opinion on the matter will be appreciated.

Thank you.
 

Attachments

  • ST16.jpg
    ST16.jpg
    108.9 KB · Views: 27
I don't know of any easy fix for this problem. It probably requires changing the main board in the controller and that could be hard to find for a good price. You have 3 choices. 1. Remove the battery after each use. 2. Send it in for repair. 3. Find a used ST16.
 
Steve, I agreed with you, discounted the battery after each used until I buy another one for a good price.
Thanks for your help.
 
I have had the same problem on both my st16 i have 2 of them I thought it was the battery iam still living with it
 
I thought I read in the depths of this forum, someone had success in placing a mini USB charging plug/ adapter into the socket and it cured the discharge Issue, not saying it will work, but worth a try.
 
Hello everyone,

Taking the opportunity of this is a place where everybody helps each other, I would like to ask for your help for the following:

I have an typhoon H, and the problem in my ST-16 CONTROLLER discharges the battery (not the drone) that it uses even when
it's being turned off. I thought the battery was having a problem and I installed a new battery and the problem continues.

At the top right in the Battery level icon indicates this symbol tool perhaps meaning that a repair needs to be done.

I had never encountered this problem before, everything was going well until now.

The battery recharges without problem. When the battery is charged and the ST-16 is turned on everything works fine.

Any opinion on the matter will be appreciated.

Thank you.
Same problem here, take out the battery when not in use.
 
Everything I have read, that is normal operation. Regardless of whether we think it should be or not. It keeps something alive in the controller.
 
The battery should drain very slowly on the STxx controllers. It is basically just keeping the clock going.

Most times if the battery is draining within a week there is an issue with the on/off switch, the charging circuit, or the microUSB port.

I have not had the problem on mine so not sure exactly what component goes bad.
 

New Posts

Forum statistics

Threads
21,044
Messages
242,746
Members
27,656
Latest member
gabor