Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up
Joined
Jan 10, 2017
Messages
19
Reaction score
3
Age
48
Recently I purchased the Itelite DBS antenna range extender to ensure stronger connections in urban areas.

Extender: https://www.amazon.com/ITELITE-DRON...rd_wg=T1fIN&psc=1&refRID=EHR5AFAW99DTFWANCFRC

I externalized the video receiver according to this video:


I flew with the new DBS antenna with no problems two times; however, now it the CGO3 camera will not connect to the ST16. I can see the wifi network the camera creates on my phone, but the ST16 will not pick it up on the bind page.

I have attached photos of the modification, and if anyone could help me figure out what is wrong it would be much appreciated.

Thank You IMG_6091.JPG IMG_6092.JPG IMG_6093.JPG IMG_6094.JPG
 

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
8,291
Reaction score
4,771
Location
Bessemer, MI
The first thing I would try.......go to Pad, Settings, WIFI and see if the camera is listed. If it shows in the list then you know the ST16 is getting the signal.
Create a new model and do the binding process again.
 
Joined
Jan 10, 2017
Messages
19
Reaction score
3
Age
48
The first thing I would try.......go to Pad, Settings, WIFI and see if the camera is listed. If it shows in the list then you know the ST16 is getting the signal.
Create a new model and do the binding process again.

Thanks for the suggestion. I'll try that now.
 

New Threads

Members online

Forum statistics

Threads
20,432
Messages
236,442
Members
25,618
Latest member
Julson20