Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Typhoon H plus no take off

Joined
Jul 14, 2021
Messages
29
Reaction score
0
Age
65
Could it be the number or stregth of both GPS locks? My H Plus occasionally refuses to start rotors, even though I appear to have plenty of satellites on both total and positioning readings.
And what do you do to start the rotors?
 
Joined
Jul 28, 2018
Messages
55
Reaction score
10
Age
59
I simply have to wait until the system cooperates. If I keep pressing the red start button, the rotors will often start, even though the satellite indicators appear the same. Weird.
 
Joined
Jul 14, 2021
Messages
29
Reaction score
0
Age
65
I simply have to wait until the system cooperates. If I keep pressing the red start button, the rotors will often start, even though the satellite indicators appear the same. Weird.
Yes, it's strange, but I will definitely try this method. Thank you for the advice. Mike.
 
Joined
Jul 14, 2021
Messages
29
Reaction score
0
Age
65
15:04h Take-off detected
15:07h Landing detected
Was this a manual flight?
No other message when trying to start in Angle Mode? Did you try it at this time?
The message No home position is a strong hint to missing GPS fix.

We really need the flight2logs, especially the latest sensor files (Sensor_xxxxx.txt where xxxx is a number).

br HE
Maybe there is some other way to forward the flight log, for example, by e-mail? We are a small European country and there is no Yuneec representative office. The only hope is for you. Mike.
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
7,491
Reaction score
4,323
Location
Genesee, MI USA

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
7,491
Reaction score
4,323
Location
Genesee, MI USA
I will prepare a smaller flight log so that it fits on the forum.
I uploaded it to my Google Drive and linked to it in my previous post so no need to do that Mike.
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
3,336
Reaction score
2,594
Location
North Carolina Piedmont, USA
We are a small European country and there is no Yuneec representative office. The only hope is for you. Mike.
There is some information in the flight log from earlier flights that might have been an issue building up to the problem. But there is also a break point in your results that might be a different sort of clue. On June 14, the logs record a session of the controller on the simulator. Flights before that simulator session were successful. Flights after that simulator session were only successful if in Sports mode. That seems interesting. To pursue that as a possible thought, we need a couple of things:
1,) Please try a fresh, complete rebind of the aircraft/camera/controller to see if it will make any difference.
2.) Looking at the LEDs under the two rear motors; What color are they when the controller is in "Angle Mode".
3.) Looking at the controller settings screen when the aircraft is bound, please verify "Manual Mode" and "Aircraft GPS Switch" are both set to OFF.
Switches.jpg
 
Joined
Jul 14, 2021
Messages
29
Reaction score
0
Age
65
There is some information in the flight log from earlier flights that might have been an issue building up to the problem. But there is also a break point in your results that might be a different sort of clue. On June 14, the logs record a session of the controller on the simulator. Flights before that simulator session were successful. Flights after that simulator session were only successful if in Sports mode. That seems interesting. To pursue that as a possible thought, we need a couple of things:
1,) Please try a fresh, complete rebind of the aircraft/camera/controller to see if it will make any difference.
2.) Looking at the LEDs under the two rear motors; What color are they when the controller is in "Angle Mode".
3.) Looking at the controller settings screen when the aircraft is bound, please verify "Manual Mode" and "Aircraft GPS Switch" are both set to OFF.
View attachment 28291
A. I am very grateful for your desire to help me. 1. Re-attached the camera and drone to the ST16s controller. 2. The rear lights flicker purple in "angle" mode. 3. Switch manual mode and GPS in "OFF" mode. The result is unchanged - in manual mode H plus flies, in "angle" mode it does not start. The distance readings from the controller to the drone are arbitrary each time and do not change if I move away at any distance. Mike.
 

Attachments

  • Flight2Log[1].zip
    85.3 MB · Views: 1
Joined
Jul 12, 2021
Messages
10
Reaction score
7
Age
46
Location
Poznan / Poland
I've had numerous cases with not arming Typhoon H. The most popular issue: broken GPS module. Sometimes you only have to replace this small pill battery on board, sometimes the whole unit and sometimes - what is the worst - there's a problem with communication between GPS and FC, and ou need to replace your FC. But for a start I would try:
1. unbind and bind everything together again (you say it doesn't work),
2. reinstall firmware (drone + camera + controller),
Typhoon H won't start in Angle mode without valid GPS data - and that's what you're missing.
 
Joined
Jul 14, 2021
Messages
29
Reaction score
0
Age
65
I've had numerous cases with not arming Typhoon H. The most popular issue: broken GPS module. Sometimes you only have to replace this small pill battery on board, sometimes the whole unit and sometimes - what is the worst - there's a problem with communication between GPS and FC, and ou need to replace your FC. But for a start I would try:
1. unbind and bind everything together again (you say it doesn't work),
2. reinstall firmware (drone + camera + controller),
Typhoon H won't start in Angle mode without valid GPS data - and that's what you're missing.
Thanks for the advice, I will try. Mike.
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
7,491
Reaction score
4,323
Location
Genesee, MI USA
I've had numerous cases with not arming Typhoon H. The most popular issue: broken GPS module. Sometimes you only have to replace this small pill battery on board, sometimes the whole unit and sometimes - what is the worst - there's a problem with communication between GPS and FC, and ou need to replace your FC. But for a start I would try:
1. unbind and bind everything together again (you say it doesn't work),
2. reinstall firmware (drone + camera + controller),
Typhoon H won't start in Angle mode without valid GPS data - and that's what you're missing.
Realize that Mike’s aircraft is the H Plus and not the H480 with the known failed IMU on the F/C when this is occurring. It is quite possible that the GPS module or its cabling is the issue as observing several missions before this happened there were many with GPS drops during the flight when viewing the kml file in Google Earth Pro.

The issue seems to be exacerbated by the use of the flight simulator on 06/14/22 and not being able to arm in Angle mode since that time.

If a complete rebind of the system does not clear the issue, I would suggest removing the top cover and clean the connector for the GPS module and reinstall it after twisting the cabling for it so the wires are not just laying straight and parallel. This should help reduce EMI on the signals on that cable.
 
  • Love
Reactions: WTFDproject

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
3,336
Reaction score
2,594
Location
North Carolina Piedmont, USA
A point that bothers me is that the craft will start in Sport Mode. Perhaps I am wrong, but I don't think Sport Mode disables GPS. I experimented on my HPlus last evening. The motors did not start in either Angle OR Sport Mode until adequate GPS was acquired.
 
  • Like
Reactions: Frontier
Joined
Jul 23, 2018
Messages
107
Reaction score
69
Location
Chios, Greece
A point that bothers me is that the craft will start in Sport Mode. Perhaps I am wrong, but I don't think Sport Mode disables GPS. I experimented on my HPlus last evening. The motors did not start in either Angle OR Sport Mode until adequate GPS was acquired.
Correct, Sport mode DOES need GPS fix to work.
 
  • Like
Reactions: WTFDproject
Joined
Jul 12, 2021
Messages
10
Reaction score
7
Age
46
Location
Poznan / Poland
Realize that Mike’s aircraft is the H Plus and not the H480 with the known failed IMU on the F/C when this is occurring. It is quite possible that the GPS module or its cabling is the issue as observing several missions before this happened there were many with GPS drops during the flight when viewing the kml file in Google Earth Pro.

The issue seems to be exacerbated by the use of the flight simulator on 06/14/22 and not being able to arm in Angle mode since that time.

If a complete rebind of the system does not clear the issue, I would suggest removing the top cover and clean the connector for the GPS module and reinstall it after twisting the cabling for it so the wires are not just laying straight and parallel. This should help reduce EMI on the signals on that cable.
You're right - problem with FC is the least likely :) So GPS module (or this little pill battery on it and/or wiring) is the prime suspect.
 
Joined
Jul 14, 2021
Messages
29
Reaction score
0
Age
65
Realize that Mike’s aircraft is the H Plus and not the H480 with the known failed IMU on the F/C when this is occurring. It is quite possible that the GPS module or its cabling is the issue as observing several missions before this happened there were many with GPS drops during the flight when viewing the kml file in Google Earth Pro.

The issue seems to be exacerbated by the use of the flight simulator on 06/14/22 and not being able to arm in Angle mode since that time.

If a complete rebind of the system does not clear the issue, I would suggest removing the top cover and clean the connector for the GPS module and reinstall it after twisting the cabling for it so the wires are not just laying straight and parallel. This should help reduce EMI on the signals on that cable.
You guys are just great. You are helping me so much that my H plus just has to take off. I'll take care of the GPS.
 

h-elsner

Premium Pilot
Joined
Mar 23, 2016
Messages
1,602
Reaction score
1,207
Location
Bavaria / Germany
The GPS module is OK. We reach GPS fix relative fast Fix Type "3D position", later it switches to "DGPS/SBAS aided 3D position" which is the best you can get without RTK capability.

The backup battery on the GPS module as reason of problems is a myth. The backup battery is only for faster GPS fix, not for better one.

No, I think, the GPS support is switched off by intention. Can you please double-check GPS setting in ST16?

In a relative early phase the parameter EKF2_AID_MASK is set to 0x20. That means, GPS is not part of the calculation. All following symptoms are related to this (no home position, GUIDED_ENABLED in MAVmode, reject Angle mode and so on).

In case Angle Mode is allowed, the parameter EKF2_AID_MASK is set 0x21=0010 0001 (bit 0 means use GPS).

I have compared two flights:
- With Angle mode: 00410, related sensor files 00356+357
- Angle Mode denied: 00468, related Sensor file 00410.

The following parameter setting are shown in the Sensor file 00356:
1504 00:01:07 COM_HOME_SET : Type: 6, Index: 134, Count: 802, Value: 0
1505 00:01:07 RTL_RETURN_ALT : Type: 9, Index: 610, Count: 802, Value: 35
1506 00:01:07 LNDMC_ALT_MAX : Type: 9, Index: 290, Count: 802, Value: 120
1507 00:01:07 RC_TESTPILOT : Type: 6, Index: 604, Count: 802, Value: 0
1508 00:01:07 EKF2_AID_MASK : Type: 6, Index: 165, Count: 802, Value: $21=0010 0001
1510 00:01:07 COM_LED_MODE : Type: 6, Index: 136, Count: 802, Value: $01=0000 0001
1515 00:01:07 COM_HOME_SET : Type: 6, Index: 134, Count: 802, Value: 0
1517 00:01:07 RTL_RETURN_ALT : Type: 9, Index: 610, Count: 802, Value: 35
1518 00:01:07 LNDMC_ALT_MAX : Type: 9, Index: 290, Count: 802, Value: 120
1519 00:01:07 COM_LED_MODE : Type: 6, Index: 136, Count: 802, Value: $01=0000 0001
1520 00:01:07 RC_TESTPILOT : Type: 6, Index: 604, Count: 802, Value: 0
1524 00:01:07 EKF2_AID_MASK : Type: 6, Index: 165, Count: 802, Value: $21=0010 0001
1533 00:01:07 COM_LED_MODE : Type: 6, Index: 136, Count: 802, Value: $01=0000 0001

And in contrast in Sensor file 00410:
1792 00:01:10 COM_HOME_SET : Type: 6, Index: 134, Count: 802, Value: 0
1793 00:01:10 RTL_RETURN_ALT : Type: 9, Index: 610, Count: 802, Value: 20
1794 00:01:10 LNDMC_ALT_MAX : Type: 9, Index: 290, Count: 802, Value: 120
1795 00:01:10 COM_LED_MODE : Type: 6, Index: 136, Count: 802, Value: $01=0000 0001
1796 00:01:10 EKF2_AID_MASK : Type: 6, Index: 165, Count: 802, Value: $20=0010 0000
1797 00:01:10 RC_TESTPILOT : Type: 6, Index: 604, Count: 802, Value: 0
1800 00:01:10 RTL_RETURN_ALT : Type: 9, Index: 610, Count: 802, Value: 20
1802 00:01:10 LNDMC_ALT_MAX : Type: 9, Index: 290, Count: 802, Value: 120
1803 00:01:10 COM_HOME_SET : Type: 6, Index: 134, Count: 802, Value: 0
1804 00:01:10 COM_LED_MODE : Type: 6, Index: 136, Count: 802, Value: $01=0000 0001
1805 00:01:10 RC_TESTPILOT : Type: 6, Index: 604, Count: 802, Value: 0
1806 00:01:10 EKF2_AID_MASK : Type: 6, Index: 165, Count: 802, Value: $20=0010 0000
1815 00:01:10 COM_LED_MODE : Type: 6, Index: 136, Count: 802, Value: $01=0000 0001
2302 00:01:18 LNDMC_ALT_MAX : Type: 9, Index: 290, Count: 802, Value: 20
3915 00:01:44 COM_HOME_SET : Type: 6, Index: 134, Count: 802, Value: 0
3916 00:01:44 LNDMC_ALT_MAX : Type: 9, Index: 290, Count: 802, Value: 20
3917 00:01:44 RTL_RETURN_ALT : Type: 9, Index: 610, Count: 802, Value: 20
3918 00:01:44 COM_LED_MODE : Type: 6, Index: 136, Count: 802, Value: $01=0000 0001
3919 00:01:44 RC_TESTPILOT : Type: 6, Index: 604, Count: 802, Value: 0
3920 00:01:44 EKF2_AID_MASK : Type: 6, Index: 165, Count: 802, Value: $20=0010 0000
3925 00:01:44 COM_LED_MODE : Type: 6, Index: 136, Count: 802, Value: $01=0000 0001

Maybe a PX4 Autopilot expert can say more about the GPS handling.
However, my eyes are directed to the ST16...

br HE
 
Last edited:
  • Like
Reactions: WTFDproject

New Threads

Members online

Forum statistics

Threads
20,431
Messages
236,440
Members
25,615
Latest member
quynh2306