Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

  1. Jeffrey Solorio

    Joined:
    Nov 8, 2015
    Messages:
    74
    Likes Received:
    10
    So I received my Typhoon H early this morning today and unfortunately either my battery or charger is defective. When I plug the battery in to the dock nothing happens the green flashing light keeps flashing green but some times it beeps with a blue flashing light. Has anyone had this issue? I'm so disappointed.
     
  2. Buddy Collins

    Joined:
    Sep 29, 2015
    Messages:
    194
    Likes Received:
    17
    Location:
    San Antonio, Texas
    I feel your pain.. Received my H this afternoon (friday) and my Battery Charger works, BUT my ST-16 will not initialize! Blue power light indicates it is getting power but nothing shows on the screen..
    Trade you my problem for yours!
     
    Jeffrey Solorio likes this.
  3. Jeffrey Solorio

    Joined:
    Nov 8, 2015
    Messages:
    74
    Likes Received:
    10
    Man that sucks too. I noticed I can hear a change of the fan speed when I move the controller around as if the fan is loose.
     
  4. Buddy Collins

    Joined:
    Sep 29, 2015
    Messages:
    194
    Likes Received:
    17
    Location:
    San Antonio, Texas
    I've read about that concern, it seems the Fan has come off it's mount shaft mostly due from Shipping.
    I've also read that it can be fixed by the consumer, you just have to split the case and reinstall the Fan onto the Shaft. Shouldnt be that way but what are you gonna do...
     
  5. Jeffrey Solorio

    Joined:
    Nov 8, 2015
    Messages:
    74
    Likes Received:
    10
    Maybe I'll wait for a YouTube video on how to.
     
  6. Marky

    Joined:
    Jun 1, 2016
    Messages:
    42
    Likes Received:
    14
    Location:
    Rainham Essex England
    Hey I'm new here and also new to the drone world but I also had this issue on my first attempt at charging, I found I hadn't pushed the battery down far enough!! With a little more force the red light came on. Before pushing though just double check you've got it in the right way by matching up with the pins.
     
  7. HarveyC

    Joined:
    Apr 22, 2016
    Messages:
    384
    Likes Received:
    126
    Make sure your charger is on (plugged in) prior to inserting the battery. I think it will just flash blue if you insert battery and then plug in charger.
     
  8. Gyro108

    Joined:
    Dec 5, 2015
    Messages:
    206
    Likes Received:
    67
    Location:
    West Midlands, UK
    The first time I used the charger I powered the charger and then inserted the battery, I also got the blue flashing light and it would do the same every time I inserted 2 different batteries. I then power cycled the charger with a battery in it and it started to charge. I have used the charger many times since and have not seen the blue light again when I insert the battery (charger powered before inserting battery).
     
  9. Wafdy1

    Joined:
    May 24, 2016
    Messages:
    3
    Likes Received:
    1
    Location:
    Kent Uk
    Hi, Same problem, I had to push the battery in with a gentle force to get it to work..
     
  10. Laura Turbeville

    Joined:
    May 17, 2016
    Messages:
    151
    Likes Received:
    57
    Location:
    Baytown, TX
    I did the same thing!! Make sure your battery is all the way pushed down! I'm glad y'all did the same thing... I thought I was having yet another blonde moment