Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

CGO3 Flashing Green

Discussion in 'Q500+ Help' started by Breki, Oct 17, 2016.

Tags:
  1. Breki

    Joined:
    Oct 17, 2016
    Messages:
    11
    Likes Received:
    1
    Hi there!

    I've been having problems getting the steadygrip to work, the WiFi doesn't appear on my iPhone, but everything works fine when it's all connected to my drone instead. I had a crash back in the days which separated the three wires inside the gimble, but the rattail cable has worked well as a replacement for it until I take the time to solder it.

    Anyway, I decided I wanted to get the steadygrip to work, so I decided to update the firmware on my CGO3. I took the memory card, formatted it and copied over the file cgo3_2.4.00_E_firmware.bin (I'm in Europe) to the root directory. Now, when I start up the CGO3 while connected to the drone and/or the steadygrip, the light just flashes green. It doesn't seem to start the firmware upgrade or anything, and now I can't even connect to the camera from my drone remote control.

    Any thoughts?
     
  2. Breki

    Joined:
    Oct 17, 2016
    Messages:
    11
    Likes Received:
    1
    I should probably point out that it's the light on the inside part of the gimbal that is flashing green, not the light on the front of the camera. If I change modes on the steadygrip, the light begins blinking slower (but still blinking green), so it appears to be doing _something_ at least. The firmware just isn't updating the way it should, the file just stays there on the memory card and I can't access my camera through WiFi on the phone or my drone remote.