Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

  1. NoCoOutdoorGuys

    Joined:
    May 13, 2016
    Messages:
    182
    Likes Received:
    31
    I've only used the battery once and only flew it to 14.7v. What would cause it to error out? I've tried unplugging and replugging the charger and reseating the battery.
     
  2. DroneClone

    Joined:
    Mar 2, 2016
    Messages:
    1
    Likes Received:
    8
    Location:
    Texas
    Others and I have had the blue ite too. I found that it happens in two way, you have the battery in the charger before you plug charger in, and if you do not plug charger in , let it blink colors and settle to solid GREEN and then insert battery. The charger seem to somewhat boot up for 20 seconds before a solid green? Have you tried that?
     
  3. NoCoOutdoorGuys

    Joined:
    May 13, 2016
    Messages:
    182
    Likes Received:
    31
    Thanks! It took several reboots of the charger but I think it's good now.
     
    DroneClone likes this.
  4. DroneClone

    Joined:
    Mar 2, 2016
    Messages:
    1
    Likes Received:
    8
    Location:
    Texas
    Great ! I have found it is pretty touchy !
     
  5. MikeB

    Joined:
    Jun 1, 2016
    Messages:
    47
    Likes Received:
    8
    I had the same problem, beeping was driving me nuts. Found out I had to push the battery pretty hard into the charger for it to seat correctly.
     
  6. Samuel Fowler

    Joined:
    Jun 7, 2016
    Messages:
    130
    Likes Received:
    56
    Location:
    Chicago
    I know how you feel when you see that blue light. :)
     
    NoCoOutdoorGuys likes this.