Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

Q500 4K drifting to the right

Discussion in 'Q500 4K Discussion' started by David Armstrong, Sep 13, 2016.

  1. David Armstrong

    Joined:
    Jun 8, 2016
    Messages:
    231
    Likes Received:
    57
    I have performed the compass calibration successfully several times and for some reason my drone keeps wanting to drift to the right.
    Even when I don't have my hands on the sticks, it slowly drifts to one side and I have to keep correcting it.
    It makes it kind of hard to fly.
     
  2. wedbster

    Joined:
    Dec 19, 2015
    Messages:
    217
    Likes Received:
    45
    1) if you don't follow this, you can get a wrong result for your calibration

    Step 1: Do not calibrate compass inside parking structures, near buildings and metal
    core roads. For best performance, only calibrate in open elds far away from power
    lines and other metallic or concrete structures.

    2) calibrate also your Accelerometer

    3) and check this
     
    WEDWay likes this.
  3. Bird Man

    Joined:
    Nov 6, 2016
    Messages:
    2
    Likes Received:
    1
    Hi I am new here , this is my first post. I have had a q500+ for a year now and have had quite a few problems with it. Right now it is drifting to the right badly with the nose pointing away from me. In fact the last two flight attempts it tips over on its side on start up. I have been instructed to do all the updates and calibrations. which I have done to the best of my ability. It appeared as I did them it was all done correctly. All this computer support for this unit seems overcomplicated. I came across the above while searching for answers. I have done this calibration as instructed. The controller does not properly calibrate in the first step, I have repeated the calibration several times hoping it would work ,but J4 never turns green and J2 sometimes does not turn green. All the other test passed. I am working with a st10+ controller ...puzzled .....what now?
    Thanks
     
    davidnclearlaketx likes this.
  4. davidnclearlaketx

    Joined:
    Mar 14, 2016
    Messages:
    34
    Likes Received:
    3
    Location:
    Clear Lake TX
    Sounds to me like the ST-10+ has a defective part in it.
    You might have to send it back to Yuneec for them to test/repair it.
    If you know anyone close by or there is a hobby shop that sells the Yuneec branded products they could use their good/working ST-10+ to bind to your Q and see if it does fine with another controller.
    It sounds like from your description your ST-10+ is the problem.
    A guy on the other forum has a used but excellent condition ST-10+ for sale for $85.00 which is an excellent price!!
    Q500 4K All Parting Out
     
  5. Bird Man

    Joined:
    Nov 6, 2016
    Messages:
    2
    Likes Received:
    1
    Thanks for your reply and information. I have taken the controller and quad to a service center and am waiting their diagnosis. I will try to remember to report back the findings when they get back with me.