Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

Trouble with GPS

Discussion in 'Q500 4K Help' started by John N Kronyak III, Dec 13, 2015.

  1. John N Kronyak III

    Joined:
    Nov 22, 2015
    Messages:
    24
    Likes Received:
    1
    Just took my maiden voyage with my Q500 4K. Calibrated the compass. Made sure GPS was ON. Sunny day with very thin clouds. ST10 indicated 14 Satellites and 19 for the Q500. The main LED continued to flash Purple(Angle Mode). GPS coordinates were visible. GPS Mode indicated ready. It seemed to be telling me I had no GPS signal. Took off in a bit of wind and was not drifting. Any ideas. I'm not sure if I had GPS lock or not . Purple LED should have remained on, not flashing.
     
  2. dmsmoke261

    Joined:
    Jun 5, 2016
    Messages:
    8
    Likes Received:
    2
    I have the same problem with the gps signal lock. Purple light flashing alternating with white light. It never goes away. Also, it sporadically flies crazy, like it doesn't know which direction is north, and it will climb for about 3 seconds on its own. Did you ever find out how to fix your problem?
     
  3. Jafo

    Joined:
    Apr 30, 2016
    Messages:
    61
    Likes Received:
    9
    A couple of updates ago, the led indicator was changed.
    What the flashes are now telling you is that your locked onto enough sats to reliably use the "Follow me and Watch me" features.
    All perfectly normal and your good to go.
    Happy flying,
    Jafo
     
    dmsmoke261 likes this.