Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Drone is connected to another controller

Mar 29, 2020
Reaction score
Ive been having an issue with my Mantis G. When i try to connect the controller, I’ve been getting the error message “drone is connected to another device”. How do i do a reset of the Mantis G? I’m not sure if its a wireless issue or a software issue. I’ve had no crashes or any other issues. Its been flying like a dream with no issues up to now. Any suggestions to get this working would be appreciated!
Is it connecting to the phone’s WiFi possibly?
I find it very difficult to believe Yuneec has not published a full user manual for the Mantis G, but the binding procedure is the same for both G and Q models. Refer to the binding procedures in the attached Mantis Q manual.


  • Mantis Q_USER MANUAL_V1.0_20180921.pdf
    2.1 MB · Views: 19
So i figured this out- thanks to everyone for the help! Connecting to the phone’s wifi was the issue. I had been launching the pilot app before connecting the controller to the phone. The order everything is turned on and connected is more important than i realized. For anyone having issues in the future that might come across this problem:

1). Turn on the Mantis(g or q) first
2) Turn on the controller
3) connect the phone to the controller
4) Open the Pilot app on your phone last.

Im so happy and impressed with the Mantis G. I think Yuneec has a great product here, I just wish it got some more accessory support.
  • Like
Reactions: Mike Irish
I tried the procedure above and my Mantis Q still says that it is connected to another device ?
I am from Las Vegas where can I send it for repair ?
In the event that you get a notice that says your Mantis G is bound to another controller here is a procedure you can follow to reconnect to the aircraft.

Power on the controller/phone and the aircraft. If all you see is the [Disconnected] at the bottom of the main app screen select it and then select Skip at the next screen.

Now select the Settings icon:

Select the Controller icon:

Swipe up to scroll to the bottom of the menu:

Select RC Binding:

Select Unbind:

Select Search:

If the Wi-Fi is functional on the aircraft it should appear in the list within a few seconds. When it does select the aircraft’s SSID and if asked enter the password found on the sticker on the side of the aircraft. It should then bind to the controller and return to the FPV screen in the app.
  • Like
Reactions: WTFDproject
doesnt help. "drone is controlled by another device" ...
tanks for reply
After unbinding the controller when you do the search does the aircraft SSID show up?

You should also be able to go to your phone’s WiFi setup and see the aircraft’s SSID.

The SSID should be in the form MantisG_xxxxxx where the x’s are the last 6 characters of the MAC address of the aircraft’s WiFi.
Is there another phone or other WiFi device within range that was connected to the Mantis G in the past that may be connecting before the device you are currently using? The Mantis G can only connect to one device at a time. This is to prevent another person being able to connect and take control of the aircraft.

Once it shows up in the RC binding screen I showed in the photos I posted it should bind to the RC/phone you are using.
  • Like
Reactions: 7cyclops
Can you take the drone and phone about a mile or so from your current location and try again?
Seems like that should eliminate any question of automatically binding to something else due to a previous bind.
  • Like
Reactions: 7cyclops
Power on the aircraft, then using just the phone go to the phone’s Wi-Fi and look for the MantisG_xxxxxx SSID. Select it then select the option to forget this network. Power down the aircraft.

Now hook the phone and controller together via USB from the larger rectangular USB-A connector on the RC controller. Power on the RC, then power on the aircraft. Now open the Yuneec Pilot app and try the normal binding procedure.
bindind failed in QR
manual (connect to wifi by manual procces password in WLAN setting in iphone, iam use iphone 14 pro than the app function working but this not. same problem... any ideas?
Try getting ahold of Vertigo Drones and have them verify that you have the correct password for the SSID that shows up. This is almost sounding like it fails to bind due to an improper password.

I know they have to software to reference the password for each SSID in the Mantis series both Q and G.

Try messaging @joe@vertigodrones if you can’t get in touch with VD’s tech support.
password working, if i manual connect its connect me (in breeze app for yuneec BREEZE shows up camera (camera working but i cant remote control with the breeze app) i installed only to the test if the wifi work but yes, work so i unninstall it and the yunnec pilot app doesnt working (dron is connected but show only drone controlled by anmother device) (it doesnt by the app breeze but the problem i have all time...) any ideas?
You can try using just the phone to bind and fly in Phone (WiFi) mode. Distance is restricted to 262 feet, but it will aid in troubleshooting the issue. Follow Method B in the Manual binding mode starting on page 11 of the attached manual to connect to the phone.

This may be an issue with the RC itself having a WiFi problem. You may have to open the RC and check the antenna connections. Are your antennas restricted to rotating down 90° and toggling up to 45° and 90° horizontal? If not then the coax cable inside the RC may be damaged.


  • User-Manual-4226929.pdf
    2.3 MB · Views: 3
Are you saying you get the same message when you try to connect to just the phone itself without the RC being connected and powered on?

If that is the case, then I don’t understand how you were able to connect to it with Breeze Cam and see the video stream.

Try contacting YuneecSkins.com or VertigoDrones.com for repair.

Members online

Forum statistics

Latest member