Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

  1. Hunter_Michael

    Joined:
    May 28, 2016
    Messages:
    195
    Likes Received:
    64
    Location:
    Fairhope, Alabama
    8/16/16 - Well I got the email today stating they were looking at my H. Then about 4 hours later I get another email stating my order has been fulfilled with a replacement of the "Typhoon H ESC Velometer Circuit Board". They replaced the GPS last visit. Would the ESC board have anything to do with the erratic toilet bowl effect I have been experiencing? I sure hope it comes back this time working correctly.
     
    #1 Hunter_Michael, Aug 16, 2016
    Last edited: Aug 24, 2016
    Rayray likes this.
  2. Rayray

    Rayray Moderator
    Staff Member

    Joined:
    Jun 3, 2016
    Messages:
    1,242
    Likes Received:
    391
    Location:
    Pine Forests of Deep East Texas
    Above my pay grade, but you are definitely having more than your share of trouble.
    Kindly keep us posted.
     
    Hunter_Michael likes this.
  3. abinder

    Joined:
    Jul 16, 2016
    Messages:
    301
    Likes Received:
    60
    It would probably depend on if the ESC board only supplies the voltages to the motors or also doubles as supplying a constant voltage to the GPS circuit.


    Sent from my iPhone using Tapatalk
     
  4. Hunter_Michael

    Joined:
    May 28, 2016
    Messages:
    195
    Likes Received:
    64
    Location:
    Fairhope, Alabama
    8/22/16 - Got my H back today and found they replaced my ST16 and originally thought they replaced my H but actually it's the original one I had or atleast the serial number is the same but it had new tags on the arms. Paperwork stated they replaced the Electronic Circuit Board on the bird. My camera showed up pulled off the rubber stabilizer pads which is strange. It was missing one of the plastic washers that held one of them on. Will do a full test tomorrow and see how she works. Wish me luck.

    This is the part they showed replaced;
    typhoonhcontrolboardtop_1000px_thumbnail.jpg
     
    #4 Hunter_Michael, Aug 23, 2016
    Last edited: Aug 24, 2016
  5. Hunter_Michael

    Joined:
    May 28, 2016
    Messages:
    195
    Likes Received:
    64
    Location:
    Fairhope, Alabama
    8/23/16 - Just went out and flew my H (one battery and half my other new battery so far) and it flew flawlessly without any issues. Extremely happy right now.
     
    #5 Hunter_Michael, Aug 23, 2016
    Last edited: Aug 24, 2016
  6. Hunter_Michael

    Joined:
    May 28, 2016
    Messages:
    195
    Likes Received:
    64
    Location:
    Fairhope, Alabama
    8/24/16 - Another Full battery flight this morning and all was great until I went to land and my camera stopped facing forward at the end probably 14.6v left on battery. I got nervous cause it started to get a little unstable when I went to land but landed without incident. The unstableness was not anywhere near the toilet bowl issues I had before. I turned off the H and booted it back up and the camera operations started working again. Going to keep an eye on this now. It has me nervous, its funny how these issues seem to happen when my battery level is low.
     
    QuadBart likes this.
  7. Hunter_Michael

    Joined:
    May 28, 2016
    Messages:
    195
    Likes Received:
    64
    Location:
    Fairhope, Alabama
    8/24/16 - Another perfect flight today!! Tested the auto takeoff, Return to Home, follow me mode with no issues. Went out pretty far over a wooded area and the video connection stayed pretty decent. Had a couple flickers but that was expected from where it was at. Just went higher in altitude once I had the flicker and it re established fine. Had a Coast Guard Helo fly over, once I heard the rotors I came down pretty fast. They fly awful low sometimes and me being retired from the Coast Guard I wanted to be a good shipmate :)