Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

  1. Ian Palmer

    Joined:
    May 20, 2016
    Messages:
    8
    Likes Received:
    1
    Location:
    London
    HI all, Im having the the exact same problem as a few others it seems (but have not seen a solution online).

    The WIFI button on my ST16 will no longer switch on, it remains greyed out (in PAD function too) and it will no longer bind with the Cgo3+

    (The H itself is bound with the ST16 with no problems)

    I can connect to and view the camera on my Android app, so I know the camera by itself is working fine)

    Anyone have a solution please?
     
  2. Steve Carr

    Steve Carr Moderator
    Staff Member

    Joined:
    Dec 15, 2015
    Messages:
    902
    Likes Received:
    401
    Location:
    Bessemer, MI
    Try opening the PAD, go to Settings and make sure the Wifi is turned on. Tap the (More...) button and make sure Airplane mode is not checked. Go back and tap on Wifi and you should see a list of any wifi signals close by including the CGO3. If you don't see any signals you will have to call Yuneec. Post back here what you find.
     
    abinder likes this.
  3. Ian Palmer

    Joined:
    May 20, 2016
    Messages:
    8
    Likes Received:
    1
    Location:
    London
    Thanks Steve, but the problem was not resolvable, so Yuneec replaced the ST16 yesterday, so in that way my problem is now resolved ☺️
     
    abinder likes this.
  4. Steve Carr

    Steve Carr Moderator
    Staff Member

    Joined:
    Dec 15, 2015
    Messages:
    902
    Likes Received:
    401
    Location:
    Bessemer, MI
    Glad you have it resolved. Happy flying!!!:)
     
    Ian Palmer likes this.