Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

Trouble with Snapshots

Discussion in 'Q500 4K Help' started by Daveola, Jul 30, 2016.

  1. Daveola

    Joined:
    Jul 30, 2016
    Messages:
    2
    Likes Received:
    0
    I just got my Q500 4K and Im hoping I didnt set something up correctly. When I press the snapshot(still shot) button on the remote it makes the shutter noise and seems like it is taking a photo but then a red error appears at the top of the screen and says something like ERROR Could not save snaphot. The video recording works perfectly however. Any ideas?

    Thanks
     
  2. FilmIdol

    Joined:
    Oct 16, 2015
    Messages:
    64
    Likes Received:
    13
    Location:
    Central Oregon
    a) You can't take a snapshot while you're recording video.
    b) I find snapshots tricky if you are out of range - even 600'.
     
  3. Kare

    Joined:
    Jul 16, 2016
    Messages:
    1
    Likes Received:
    1
    Hello Daveola. I have had the same issue on my 4K, here is what you can try to solve it: Press the "settings", chose "camera" and chose the CGO3Pro option instead of the CGO3. Then you will get a more advanced screen to look at. On the right side of the screen you will find a film camera symbol, if this is highlighted (red) you cannot take photos. Then press the camera symbol instead, turns red... There you go: Take your snap shots! :) Good luck and fly safe!
     
    Daveola likes this.
  4. Daveola

    Joined:
    Jul 30, 2016
    Messages:
    2
    Likes Received:
    0
    Thanks Kare! That was it. Works perfectly now.