Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Recent content by Texas_Willie

  1. Texas_Willie

    Flashing Blue Light

    Update: I just now got the GUI to work and when I tested the motors...Now they all work without any problem...go figure! I think one of the motors may have had some sand or dirt jammed in it (even though I blew them all out as best I could first)...Bottom line, once I got the GUI to work, all...
  2. Texas_Willie

    Flashing Blue Light

    That may very well be what was going on, I'm just glad I was able to get it to bind....FINALLY! Now that I have that fixed, I have a motor or two to replace! Since I couldn't test anything without the bind, I have a motor that threw land warning in testing and so if anyone has any tips on...
  3. Texas_Willie

    Flashing Blue Light

    You know what...Screw you guys...I followed instructions previously suggested here and they FAILED to work! The instructions from VD had TWO steps that were NEVER mentioned here...The first being to tip the drone "quickly 4 to 6 times" and the second being to tip the drone so the camera is...
  4. Texas_Willie

    Flashing Blue Light

    OK...Last night, I packed the drone and controller up and attached the pre-paid label that Vertigo Drones sent me and this morning I was about to leave the house to take it to the UPS Store and ship it off. Just as I was about to leave, I got a reply to an email I had sent Joe at Vertigo...
  5. Texas_Willie

    Best Buy Geek Squad

    Can anyone tell me DEFINITIVELY if Best Buy will accept Yuneec products for repair...IE Typhoon H etc. TIA TW:D
  6. Texas_Willie

    Flashing Blue Light

    Ok, so if the 2.4 GHz antenna shows up on the ST16 screen it should bind? I will fire up the ST16 and see if it does or not...Should I also start the H or just wait to see if the antenna shows up?
  7. Texas_Willie

    Flashing Blue Light

    That all works great until I get to the Rebind Drone part....It does not show up in the left column...No problem getting the camera to show up bind...:(
  8. Texas_Willie

    Flashing Blue Light

    I tried to do the firmware update, I formatted my SD Card (yes it is the correct card), copied the file (ST16_V3.1.30.yuneec) inserted it into the SD16 controller, went to System Settings >About Controller>Update and get the Message "WARNING!!! No firmware exists in SD card, please connect to...
  9. Texas_Willie

    Flashing Blue Light

    Even though the "About Controller" on the Bind menu shows all the correct version number for the Camera, Gimbal Controller etc?
  10. Texas_Willie

    Flashing Blue Light

    The problem is the ST16 is NOT showing up on the bind menu...The camera is there, but NOT the controller
  11. Texas_Willie

    Flashing Blue Light

    Still no go...I am at a loss...I have a trip scheduled to drive across the Country in June, the main purpose of which is to get video and photos of the many interesting sites along the way...If I can't get this fixed, I will not be able to make the trip. When I turn on the ST16, everything...
  12. Texas_Willie

    Flashing Blue Light

    Crap...I made the mistake of hitting the Team mode, got the flashing orange light. Thinking maybe I could bypass the binding...My Wizard won't connect either....Now, I can't get it OUT OF TEAM MODE. I select single and it goes right back to Team.... I have a new shotgun that I haven't shot...
  13. Texas_Willie

    Flashing Blue Light

    Hmmm, still no go....Very frustrating....
  14. Texas_Willie

    Flashing Blue Light

    I just tried that , tipping it forward over a dozen times...No Joy
  15. Texas_Willie

    Flashing Blue Light

    I crashed my H a couple of days ago and have had to do some repairs. It was a pretty hard crash, but I only lost 3 blades and the camera gimbal came off on impact...Which damaged the part that slides onto the bird. I believe I have that fixed for the moment. I have a Rapid Blue Flashing Light...