Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Beep codes for the C23/E90 camera

Joined
Jul 10, 2021
Messages
6
Reaction score
7
Location
PL
Hello,
I have searched for this on the forum, but to no avail.

Is there a table available with the beep codes for the C23/E90 camera?
 
Joined
Jul 10, 2021
Messages
6
Reaction score
7
Location
PL
Thank you very much for the information.

Unfortunately I do not find here the sequence of 3 short beeps during camera initiation.
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
3,398
Reaction score
2,670
Location
North Carolina Piedmont, USA
That one is a bit of a mystery to me. It seems to be related to a missing status indicator during the boot up check, rather than an actual error. It could also be a hint that one of the ribbon conductors is deteriorating. I just don't really know.
Does the camera gimbal boot up and work normally despite the code?
 
Joined
Jul 10, 2021
Messages
6
Reaction score
7
Location
PL
That is the crux of the problem.
The gimbal is not moving. Voltages at the test points on the Roll and Pitch encoder PCBs occur and change as the gimbal arms are rotated. There is a noticeable one-time vibration of the gimbal arm motors during camera initiation.
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
3,398
Reaction score
2,670
Location
North Carolina Piedmont, USA
That is the crux of the problem.
The gimbal is not moving. Voltages at the test points on the Roll and Pitch encoder PCBs occur and change as the gimbal arms are rotated. There is a noticeable one-time vibration of the gimbal arm motors during camera initiation.
Has the gimbal been subjected to any recent extreme movement? Ribbon damage has occurred from events like crash/hard landing, running compass/accelerometer calibrations without the gimbal lock installed, or even travel without the gimbal lock installed.
The small magnets on the roll and pitch motor sometimes experience spontaneous degradation and loss of magnetic strength. The magnet deterioration usually results in an actual error code, but it may still be worth lifting the encoders off and checking the magnets.
 
Joined
Jul 10, 2021
Messages
6
Reaction score
7
Location
PL
I have not received information about crashes/hard landings or possible mechanical damage to the gimbal. The camera housing and gimbal arms look good.
The good condition of the encoder magnets is evidenced by the PWM voltage changes depending on the angle of the arms.
I suspected damage to the gimbal motor drivers, so I have already replaced the Pitch and Roll encoders and the gimbal board.
Unfortunately without a positive result.
 
Joined
Jul 10, 2021
Messages
6
Reaction score
7
Location
PL
The problem has been solved. The gimbal is now working properly.
Repair summary:
The cause was a faulty IMU module.
It can be assumed that a single sequence of 3 short beep during C23/E90 camera initiation indicates a problem with the IMU module.

Thank you for the information and valuable suggestions.
Best regards
Mark
 

New Threads

Members online

No members online now.

Forum statistics

Threads
20,565
Messages
237,487
Members
25,947
Latest member
selnor