Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

CGO3 update failed, help needed! - solved

Joined
May 26, 2016
Messages
2
Reaction score
0
Age
32
Hi Everyone

I tried to update the CGO3 firmware from EU to STD and did that by following instructions on a German site where they suggested to change the name of the file a number higher then the current one otherwise it would not apply the update. The camera started to update (blinked purple) but then turned off. After waiting for a bit and rebooting the quad the LED went green and the connection is working but there is no live feed (no picture) on the ST10+ nor my tablet through the CGO app.

Is there a way to fix this or have I bricked the camera with my own stupidity?

Edit: Apparently the newer Q500 4K drones are running v. 02.40 FW at the camera while the older were at 1.80, there is supposed to be a difference in the HW. If you have made the same stupid mistake as I did just go to yuneec.de and download the latest FW version.

PS: It seems that there is no way to install the standard fw on the newer EU Q5004K drones.
 
Last edited:

New Threads

Members online

Forum statistics

Threads
16,833
Messages
196,543
Members
19,529
Latest member
[email protected]