Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

H520e power loss at low altitude

Joined
Oct 30, 2016
Messages
1,144
Reaction score
407
Age
45
I have to wait before I retire my first gen h520. I need to test fly it with the new power source adapter. I got a solid base line reading on the up time using the lowest capacity flight battery I have.
 
Joined
Dec 15, 2021
Messages
1
Reaction score
0
Age
69
Based on the photos it appears that the design of the battery contact did not allow enough surface area for the amount of amps that the drone needs to perform flight. Resulting in heat and melted contacts. My concern is that the heating could result in lost of contact (Power failure) The is no easy answer . Reduce amp,
redesign battery connection. Just a quick observation.
Just received the new H520E I will keep an eye on it.
 
Joined
Nov 28, 2019
Messages
495
Reaction score
276
Age
47
Location
Austin, Texas
We've got about 10 multi-battery missions into ours after the frame replacement solution and everything seems to be okay at this point. We'll definitely know when it's not, lol.
 
Joined
Dec 24, 2020
Messages
31
Reaction score
6
Age
55
Location
McLeansville North Carolina
We've got about 10 multi-battery missions into ours after the frame replacement solution and everything seems to be okay at this point. We'll definitely know when it's not, lol.
I was thinking the same thing but my concerns are what improvements did they make to the new frame to stop this problem? Vertigo drones were repairing my drone so I ask them a direct question about this issue and did not get an answer yet. So my thoughts are will there be another melt down in my future. Yuneec really needs to get a handle on this and do some damage control.
 
Joined
Oct 30, 2016
Messages
1,144
Reaction score
407
Age
45
just got about every thing I need to test out the h520e rtk unit. just now need to wait for a good weekend with out rain or snow.
 
Joined
Dec 24, 2020
Messages
31
Reaction score
6
Age
55
Location
McLeansville North Carolina
Based on the photos it appears that the design of the battery contact did not allow enough surface area for the amount of amps that the drone needs to perform flight. Resulting in heat and melted contacts. My concern is that the heating could result in lost of contact (Power failure) The is no easy answer . Reduce amp,
redesign battery connection. Just a quick observation.
Just received the new H520E I will keep an eye on it.
Thanks for you input!
 
Joined
Dec 24, 2020
Messages
31
Reaction score
6
Age
55
Location
McLeansville North Carolina
Well, here's an update! My 520E is back from Vertigo Drones and it flies well but now I have serious video lag and drop outs at close range. This problem usual happens only when you push the unit out a good distance but now I'm seeing it much less then a 100ft. Everyone knows if you are flying in close proximity with this lag and using video feed your at risk of crashing your aircraft so now up close inspections are now out of the picture. I have sent Vertigo a few emails but no replies to my requests about the repairs done to my drone and now video feed issues. I have looked at their reviews and noticed I'm not the only one not receiving correspondence. Hopefully they respond sooner then later so I can use put my done back in use so I will let you know what happens next so cross your fingers.
 
Last edited:
Joined
May 21, 2020
Messages
205
Reaction score
134
Location
England - Southwold Suffolk
Well, here's an update! My 520E is back from Vertigo Drones and it flights well but now I have serious video lag and drop outs at close range. This problem usual happens only when you push the unit out a good distance but now I'm seeing it much less then a 100ft. Everyone knows if you are flying in close proximity with this lag and using video feed your at risk of crashing your aircraft so now up close inspections are now out of the picture. I have sent Vertigo a few emails but no replies to my requests about the repairs done to my drone and now video feed issues. I have looked at their reviews and noticed I'm not the only one not receiving correspondence. Hopefully they respond sooner then later so I can use put my done back in use so I will let you know what happens next so cross your figures.
@Johnny$, I had the same issue with my H Pro that was fitted with the EU firmware but the clever folks on this forum supplied me with the US firmware all issues fixed, not saying that this is the issue with your unit, just some information for you, hope that they can help you to fix your issue
 
  • Like
Reactions: chascoadmin
Joined
Nov 28, 2019
Messages
495
Reaction score
276
Age
47
Location
Austin, Texas
Well, here's an update! My 520E is back from Vertigo Drones and it flies well but now I have serious video lag and drop outs at close range. This problem usual happens only when you push the unit out a good distance but now I'm seeing it much less then a 100ft. Everyone knows if you are flying in close proximity with this lag and using video feed your at risk of crashing your aircraft so now up close inspections are now out of the picture. I have sent Vertigo a few emails but no replies to my requests about the repairs done to my drone and now video feed issues. I have looked at their reviews and noticed I'm not the only one not receiving correspondence. Hopefully they respond sooner then later so I can use put my done back in use so I will let you know what happens next so cross your fingers.
We usually start getting a little glitchy at about 2,000ft although I do see the same issue we had with the original H520 before they improved the radio and antenna locations where it will glitch when the aircraft is turning then facing back toward you.
 

New Threads

Members online

No members online now.

Forum statistics

Threads
20,133
Messages
232,850
Members
24,655
Latest member
iwiin68