Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

H920 issue

dagmba

Premium Pilot
Joined
Oct 22, 2022
Messages
9
Reaction score
3
Age
64
I purchased a H920 (non +) recently and the CGO4 camera. (I also have the Panasonic GH4 camera and gimbal for it...) I set it up with the CGO4 attached and while the gimbal boots and turns the camera during the boot up process, it does nothing afterwards. Also, I am unable to start the motors using the ST24 controller switch, though the H920 "comes on" when I turn on the power switch. When I go to camera in the pad settings, I see a picture coming from the CGO4. I am NEW to this. The documentation is sparse and I'm not sure if I'm doing what I need to do to get this flying. The tail light flashes blue very quickly indicating it is not bound to the controller, but I don't seem to see a way to bind it despite having done the tilt maneuver which was supposed to bind it. I'm sure I'm just missing a step somewhere, but the talk of incompatibility with the legacy H920 vs H920+ and CGO4 being specific for a certain vintage, concerns me. Apologies if I am posting this in the wrong area. David in Houston
 
  • Like
Reactions: 7cyclops
I’ve attached the user manual for the H920/ST24. Follow the binding instructions starting on page 24 for Binding (Single Mode). The camera gimbal will not respond to commands until the aircraft is bound to the ST24. The rapid blue flashing on the Main LED is telling you they are not bound. When tilting the aircraft to initiate bind mode go at least 45 degrees forward (I always do more like 60) then back until you get the flashing yellow (it may take more than twice).
 

Attachments

  • h920_industry_user_manual_(st24)_v1.0.pdf
    3.3 MB · Views: 19
I’ve attached the user manual for the H920/ST24. Follow the binding instructions starting on page 24 for Binding (Single Mode). The camera gimbal will not respond to commands until the aircraft is bound to the ST24. The rapid blue flashing on the Main LED is telling you they are not bound. When tilting the aircraft to initiate bind mode go at least 45 degrees forward (I always do more like 60) then back until you get the flashing yellow (it may take more than twice).
Thank you very much. I tried this and, so far, it has not worked. What is the LK58 that is referred to? Also, when I power on the ST24 and choose FPV, then model select, I do not get the option to choose the CGO4, only "H920 GB603" or "new model" appears. I also will get the message to choose "AP WIFI" but don't see a way to do so. What am I missing?
 
I would choose the H920. It is obvious that the CGO4 is binding since you get a video feed.

The GB603 is a gimbal for a different camera and the LK58 is a video link.

If you just turn on the aircraft you should get flashing blue on the Main LED after it finished initializing. If you do the tilting, the binding mode should get set and change to flashing yellow on the Main LED. If you do not get that, it means there is an issue on the aircraft preventing binding mode. It would either be the SR24 Zigbee module or the Flight Control module.
 
  • Like
Reactions: 7cyclops
Thanks for your help. If I ONLY turn on the aircraft, it does flash blue, then yellow, following the tilt exercise. With the a/c off, when I turn on the ST24 and follow step 1 of the single mode binding instructions, it immediately goes to a screen that says:
RC:connecting...
WIFI: connecting...
The circle is twirling but it never leaves this screen. So, I seem to be stuck here. Does this make sense to you?
 
Without the aircraft and camera powered up the R/C has nothing to bind to and will display the connecting messages.

If you get the aircraft to go into the bind mode leave it on and then follow the single mode binding after the ST24 is powered up and booted.
 
I did as you suggested, ( get H920 into bind mode - success, then follow single mode bind directions - no luck) without success. Two things I don't understand: (1) I am using the CG04 (though I have a V18 and the Panasonic GH4, too) and it does not appear as a camera that I can select from the menu on the ST24 (2) I am asked to select "WIFI AP" - where do I find this setting? What does this mean?

Is this supposed to be this difficult? I bought this H920 new in the box. I'm still convinced it works, but I just am missing something that isn't clear in the sparse documentation.

Thanks again for your help.
David
 
I don't know what I did, but I was able to get the H920 to show it was paired with the ST24. I actually flew it for the first time on Wednesday and it did great! Sadly, the next time I turned it on I get a beeping sound and the indicator light is rapidly flashing blue (indicating it is not paired with the ST24 anymore). The beeps are 6 in 5 seconds followed by 4 in about 1 second, then two tones and it repeats. Any suggestions?
 
Looks like our members that had/have the H920 w/ST24 are dormant.

At this point I would suggest capturing screenshots of the ST24 as you work through each step of trying to bind and attach them in chronological order to your next post. This may help us try to resolve the issues you are having in the binding process.

The manual provided by Yuneec does not address all the screens encountered or the options available in each screen, so we are going on our best guess from our experience with other Yuneec models in our attempt to walk you through binding.
 

New Posts

Members online

Forum statistics

Threads
20,977
Messages
241,826
Members
27,373
Latest member
aimal khan