Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Not Connecting

Joined
Jan 2, 2016
Messages
4
Reaction score
0
Age
71
So I unpacked my new typhoon, read ALL the instructions, charged the batteries, and turned on the devices, but the camera won't connect to the controller. Help!
 
Joined
Dec 30, 2015
Messages
42
Reaction score
6
Do you have gold contacts on the bully of the bird where the fumble slides over?

If you do, make sure the camera is fully seated backward. I had to really use pressure (not force) to "click" the camera into place.

If you don't have contacts, there is an cable ypunhave to connect from the gimble to the bird.

Just some thoughts...
 
Joined
Jan 2, 2016
Messages
4
Reaction score
0
Age
71
Contacts are good. The controller isn't searching for a signal, I don't think, or the aircraft is not broadcasting.
 

BEE

Joined
Nov 15, 2015
Messages
56
Reaction score
10
Age
53
look in the manual under cgo3 binding..it's easy to do the actual binding of the cgo to the st10..try that
 
Joined
Jan 2, 2016
Messages
4
Reaction score
0
Age
71
Tried binding many times. Doesn't stick. Looks like st10 memory has been wiped. Guages all blank. Not even quad model is listed.
 

BEE

Joined
Nov 15, 2015
Messages
56
Reaction score
10
Age
53
I would call Yuneec customer service .....they ll get you right !!!
 
Joined
Jan 2, 2016
Messages
4
Reaction score
0
Age
71
:( I did. They were unable to help. Went through the process of updating st10 and q5004k, still no connection, no meter functions. I'm returning the whole mess for a refund.
 

BEE

Joined
Nov 15, 2015
Messages
56
Reaction score
10
Age
53
Where did you buy it ? Thats weird ???
That suks,,,,,,i
 
Joined
Mar 25, 2016
Messages
268
Reaction score
60
Age
70
Location
Tennessee
I had the same problem.

Though the model I had selected showed on the ST10+ it wouldn't find it to bind too.

Check in the manual, page 27 entitled "ST10+ and receiver binding"

Turn the Q500 4K on then holding by the back tip it forward 45 degrees then level it, repeat and the rear light should turn orange ... Then try binding.

It should show as a choice.


Hope this helps anyone in the same situation.
 
Last edited:
Joined
Nov 26, 2015
Messages
79
Reaction score
13
Age
76
[ I would call Yuneec customer service .....they ll get you right !!! ]

[ "I did. They were unable to help" ]

Now that is encouraging........ sports fans
 

New Threads

Members online

Forum statistics

Threads
16,973
Messages
198,179
Members
19,640
Latest member
mary