Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

ST16 Typhoon H binding issues

Joined
May 11, 2020
Messages
2
Reaction score
0
Age
36
Same issue here, I'm from the Caribbean, bought my Typhoon H from United States back in 2017.

About a year ago, I had a soft crash due to low battery (I didn't check properly the battery charge before flying it) and ever since that event I replaced the broken propellers, and could fly the aircraft with no image or connection to C-GO3+ camera at all. Since about 5 months ago, the ST16 doesn't connect to either the aircraft or the camera. None can be found from the ST16.

I have never been able to turn the ST16 pad's wifi on for wireless update, and the firmware update that I have been able to find online, is not recognized by the ST16 either.

Camera is slowly blinking green, aircraft is rapidly blinking blue.

I don't know what to do. Please help, I can't get anyone from the manufacturer to assist in any way.
 
Last edited:

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
3,012
Reaction score
2,329
Location
North Carolina Piedmont, USA
Same issue here, I'm from the Caribbean, bought my Typhoon H from United States back in 2017.

About a year ago, I had a soft crash due to low battery (I didn't check properly the battery charge before flying it) and ever since that event I replaced the broken propellers, and could fly the aircraft with no image or connection to C-GO3+ camera at all. Since about 5 months ago, the ST16 doesn't connect to either the aircraft or the camera. None can be found from the ST16.

I have never been able to turn the ST16 pad's wifi on for wireless update, and the firmware update that I have been able to find online, is not recognized by the ST16 either.

Camera is slowly blinking green, aircraft is rapidly blinking blue.

I don't know what to do. Please help, I can't get anyone from the manufacturer to assist in any way.
You have two problems. The camera binding and the aircraft binding are two different things, with two different sets of potential problems.

1.) The aircraft (Control WIFI) issue is probably easy. Blue is the wrong color. Tilt the aircraft forward a couple times until the rear main LED blinks orange, then complete the binding process.

2.) The video (camera WIFI) binding may be more of an issue. The green flashing on the camera probably means the camera is OK, but maybe not the controller. The controller WIFI is subject to failure from a couple of common sources. One is being left in a hot environment, such as a car trunk on a hot day. The other is if the controller has been left turned on until the battery dies. If either of these has happened, you will probably need to replace the WIFI module.

If neither of the above is helpful, you will need to run the FULL step by step binding diagnostic. The idea behind the diagnostic is to perform every step, exactly as written. The sequence will do some preliminary checks to establish the correct conditions. It will then fall into a sequence of directing an action, followed by a step to verify the proper result of the action. When you reach a step that does not meet the verification, or you are not sure, DO NOT CONTINUE. Report the step number and the actual result back here to the forum. We may be able to recommend a solution.

The step by step diagnostic is Attachment 35 (Typhoon H Binding Verification) of the PDF document attached to Way To Fix Drones project.
 
Joined
May 11, 2020
Messages
2
Reaction score
0
Age
36
Hello there, again!

I was able to successfully bind the ST16 with the aircraft (Typhoon H) as per the steps on the Attachment 35 (Typhoon H Binding Verification), Way To Fix Drones project.

However, when trying to bind the C-GO3+ camera with the ST16 (Controller), on step #81. Select the "Select" button at the lower right of the screen.

The camera is supposed to be selected or recognized on the "Select Camera" menu, from the "System Settings" screen... But I keep on getting the pop-up message: "Connection Failed - Camera not connected!"

The camera pan and tilt work. But still unable to bind with the ST16.

Note: The C-GO3+ camera was constantly vibrating, blinking green as it should, but always vibrating.


I need help from this point forward.

Thanks for the support.
 

Attachments

  • 20210624_194855.jpg
    13.4 MB · Views: 7

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
3,012
Reaction score
2,329
Location
North Carolina Piedmont, USA
Something strange is happening. The ST16 is not actually trying to connect to the camera at that step, so I am puzzled by the error message. You should be able to select ANY camera on the list, and get it to set up properly, even if the drone and camera are turned off!!

This seems to be a controller issue. Here are a couple of firmware solutions to try:
1.) First, try to do a factory reset on the controller to see if it will resolve the issue, or if any behavior changes at all.
2.) If Factory Reset does not help, try to do an update to the ST16 using the firmware in this link:
 
  • Like
Reactions: DoomMeister

New Threads

Members online

Forum statistics

Threads
20,058
Messages
232,017
Members
24,425
Latest member
[email protected]