Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Calibrate Gimbal

Joined
Apr 4, 2016
Messages
9
Reaction score
1
Location
Oakdale, Ca.
I have a Typhoon Q500 4K drone with CG03 camera that I have not flown for a couple of years and I want to use the camera with the Steady Grip for taking photos on the ground. My camera has always sat at an angle when not powered on, but always corrected itself when I would power up the drone, but on Steady Grip it does not correct itself and while trying to take a photo it starts leaning to one side to the point where I hear the gimbal motor grinding so I shut it off before it causes damage. I found a youtube video showing how to calibrate the unit on the drone but several years ago the white cable in the battery area got caught on the battery and broke the connector off so now I have 4 wires and cannot connect the USB cable to it. I was going to take the body off and solder a new connector on the wires but saw that I would need to unsolder the wires on each motor and don't want to take a chance on breaking something. Does anyone have any ideas?
 
I found a youtube video showing how to calibrate the unit on the drone but several years ago the white cable in the battery area got caught on the battery and broke the connector off so now I have 4 wires and cannot connect the USB cable to it. I was going to take the body off and solder a new connector on the wires but saw that I would need to unsolder the wires on each motor and don't want to take a chance on breaking something. Does anyone have any ideas?
Repairing the USB connector should be done at some point, but it will not help you with calibration of a CGo3. The calibration add-on in the Q500 GUI will only work for the older CGo2. And it's not much of a calibration anyway. It will not correct your issue. You probably need a new IMU and shop calibration using software Yuneec did not make public.
You can try contacting either of our sponsors for the repair. John Mitchell @Yuneec Skins may be the more practical for you since you are in Oakdale.
CGo2GB cal.jpg
 
I sent a message to John Mitchell using the link you provided but not being familiar with how this forum works I don't know how to find a reply from Mr. Mitchell. I don't see a message section in the forums so not sure where to look?
 
You will get an alert when a new message appears. But the "envelope" icon beside your avatar near the upper right of the screen will open messages manually.
 

Members online

Forum statistics

Threads
20,973
Messages
241,789
Members
27,349
Latest member
trienchieu369