Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Gimbal trouble

Joined
Oct 15, 2020
Messages
3
Reaction score
2
Age
44
I inherited a Mantis Q. I have one issue remaining. The camera functions but the gimbal works very intermently. I removed the top cover and removed and reconnected the circuit board on the top cover. With the drone powered up and the remote connected the gimbal servo motor will run for 2 seconds and then stop for 12 seconds and then repeat until the unit is powered off. The gears/shaft does not rotate during the motor running. The camera is semi-free on the gimbal. I am brand new to this. Can anyone point me in the right direction?
 
Joined
Apr 15, 2020
Messages
33
Reaction score
10
Location
N. California
Looks like you have stripped the gears on the servo. To me that is a design flaw, I had the exact same issue.
Search in this forum and you will find a solution.
 
Joined
Oct 15, 2020
Messages
3
Reaction score
2
Age
44
I did some more testing. The gears are in good shape but the servo motor shaft was not rotating. The motor would cycle on for 3 seconds and off for 13 seconds without input from the controller. I was able to finally find a replacement camera assembly (camera, gimble and servo) for $79.99. I just installed it today. I removed the servo from the old motor and was able to match one up (I hope). Pololu - Sub-Micro Servo 3.7g (Generic) is the link to the servo. $4.95 + shipping was just under $9. I'll update when I know if it will work....
 
  • Like
Reactions: DoomMeister
Joined
Oct 15, 2020
Messages
3
Reaction score
2
Age
44
The servo came today! It is an nearly direct swap. The gear pulls off the defective motor on presses right on the new. The only issue is the plug is not the same. I opened the bottom covers and de-soldered and swapped cable.
 
  • Like
Reactions: DoomMeister
Joined
Jul 2, 2019
Messages
2
Reaction score
0
Age
31
The servo came today! It is an nearly direct swap. The gear pulls off the defective motor on presses right on the new. The only issue is the plug is not the same. I opened the bottom covers and de-soldered and swapped cable.
Awesome news. I will have to do the same with my Mantis G. Though I do now have a solder. I have done some soldering before, but not on electronics. Do you know where I can view a tutorial for something similar to this project?

Thank you
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,429
Reaction score
3,700
Location
Genesee, MI USA
Awesome news. I will have to do the same with my Mantis G. Though I do now have a solder. I have done some soldering before, but not on electronics. Do you know where I can view a tutorial for something similar to this project?

Thank you
 

New Threads

Members online

No members online now.

Forum statistics

Threads
19,780
Messages
228,920
Members
23,745
Latest member
jhongkie